Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.2
    • Fix Version/s: 0.3
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP
    • Number of attachments :
      0

      Description

      We encountered some issues using the PHP CodeSniffer plugin. We found that the rules.xml file is not encoded in UTF-8 and then raises an error when it's parsed by CodeSniffer. We had to manually encode it into UTF-8 and then re-inject it in the jar.
      It seems also that the stax2 lib is used by the plugin but is not available inside the Sonar classpath. After making it available to the plugin, everything works fine.

      We really appreciate the effort you're doing on these tools.
      Right now, we're installing a SONAR PHP platform in order to test. We'll let you know how it goes.
      If we can help in any way, feel free to contact us.

      LOGICA Software Quality Center
      (We speak French and English)

        Activity

        Gabriele Santini added a comment -

        Hi, and thank you for testing the plugin.
        The first help we need is feedback and bug reporting indeed.

        We would like to be able to reproduce the issue, can you please tell us more about your environment? Which encoding do you use for OS and jvm ?

        LOGICA Software Quality Center added a comment -

        Hi Gabriele,

        We face this issue on a windows server machine with the Sun JDK 1.5 and default encoding. When using the code sniffer plugin, a parsing exception is thrown and the stack trace shows that there's something wrong with the Rule.xml file. So, after a look at that file inside the jar of the plugin, we convert it to UTF-8 and change the XML declaration to reflect this change. I'm not sure, but i remembered that the file was windows encoded (cp1512).

        Hope this will help you.

        Regards,

        Logica Software Qality Center

        Akram Ben Aissi added a comment -

        Priority lowered because a workaround exists

        Akram Ben Aissi added a comment -

        rules.xml files have been updated and encoding is correct now


          People

          • Assignee:
            Akram Ben Aissi
            Reporter:
            Anonymous
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: