SonarQube PHP
  1. SonarQube PHP
  2. SONARPHP-228

Add "sonar.<tool>.reportPath" to merge "sonar.<tool>.reportFileName" and "sonar.<tool>.reportFileRelativePath" properties

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      This should be done in order to be consistent with the way most/all existing plugins handle reusing reports.

      What's more:

      • it should be possible to set absolute paths
      • non-absolute paths should be relative to the project directory, not to the Sonar working directory of the project

      This should be done for every PHP tool.
      For every tool, "sonar.<tool>.reportFileName" and "sonar.<tool>.reportFileRelativePath" properties should be deprecated and a warning message should be written in the log if they are used.

        Activity

        Julien HENRY added a comment -

        New *.reportPath properties don't have a default value => it means report file is generated in Sonar working directory (except if deprecated props are still used in this case a warning is logged and deprecated props are used).

        Fabrice Bellingard added a comment -

        Looks like you forgot PHPCodeSniffer, PDepend & PHPMD?

        Julien HENRY added a comment -

        Should be better now

        Fabrice Bellingard added a comment -

        The new properties are working correctly.

        However:

        • there seem to have regressions on the old ones
        • "sonar.phpunit.analyzeOnly" seems to not be taken into account (PHPUnit is always executed)
        • could you also add a "Use xxx properties instead." at the end of the description of each deprecated property?
        Julien HENRY added a comment -

        Done except for sonar.phpunit.analyzeOnly because it is a case issue => sonar.phpUnit.analyzeOnly

        Julien HENRY added a comment -

        No need for IT


          People

          • Assignee:
            Julien HENRY
            Reporter:
            Fabrice Bellingard
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: