SonarQube PHP
  1. SonarQube PHP
  2. SONARPHP-13

PHP Plugins doesn't show CodeSniffer violations

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.4
    • Fix Version/s: 0.5
    • Component/s: None
    • Labels:
    • Environment:
      linux redhat, sonar 2.6 & 2.8, ant task
    • Number of attachments :
      2

      Description

      The PHP Plugin in version 0.4 doesn't import the violations reported by PHP_Codesniffer.

      The version 0.3 works as expected.

      You can find the test project attached and the codesniffer log file.

      1. codesniffer.xml
        4 kB
        Eric Colinet
      2. sonar-test.tgz
        19 kB
        Eric Colinet

        Activity

        Khalil KHOUJA added a comment -

        Hello,
        I have the same problem, codesniffer.xml contains some violations but nothing on the dashboard.

        Gennadiy Litvinyuk added a comment -

        I can't reproduce this problem with my projects, and I can't open attached tgz file.

        I have noticed, that all Violation in sample codesniffer.xml file are not activated by default. Could this be one reason of the problem?


          People

          • Assignee:
            Fabrice Bellingard
            Reporter:
            Anonymous
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: