Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.3
    • Component/s: None
    • Labels:
      None
    • Testcase included:
      yes
    • Patch Submitted:
      Yes
    • Source ID:
      #5
    • Number of attachments :
      1

      Description

      Short summary of changes:

      Pull request on GitHub: #5

        Activity

        Gleb Godonoga added a comment - - edited

        This ticket covers SONARPLUGINS-2590 as well

        Martin Naumann added a comment -

        Any chance of this getting merged and resolved in the near future?
        If I can do anything to help, let me know!

        Evgeny Mandrikov added a comment -

        @Martin We will work on that as a part of next sprint for Sonar JavaScript Plugin, but can't tell you more precisely when this will happen.

        Thanks for your understanding.

        Gleb Godonoga added a comment -

        @Evgeny,
        If someone wanted to do extensive work on the JavaScript plugin (refactoring, adding features, transitioning to more recent versions of sonar), would you accept GitHub pull requests in a timely manner or just treat that as "we will look into it at some point"?

        The problem is that you can't properly break up refactoring in small chunk and do pull request that rely on each other but are not merged. That will cause loads of PR's that should be committed all or none.

        What would you advise?
        Work independently on a fork and then issue a huge PR before you sprint starts?

        Thanks,
        Gleb

        Freddy Mallet added a comment -

        @Gleb, I fully understand your frustration but behind this javascript plugin and all Sonar plugins there are thousands of integration tests and if we merge all patches as soon as they are provided, maintaining those ITs will become a nightmare and our own internal productivity will fall. Our commitment is to do some frequent releases on each plugin and as soon as we'll start the next development sprint on Javascript we'll study your pull request. Thanks for your understanding.

        Evgeny Mandrikov added a comment -

        @Freddy you'll find an example in SONARPLUGINS-2695.zip

        Freddy Mallet added a comment -

        Manually tested !


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Anonymous
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: