SonarQube Jenkins
  1. SonarQube Jenkins
  2. SONARJNKNS-54

Jenkins Sonar plugin: link does not resolve job parameters

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I have created a job using as post build action the sonar jenkins plugin. in advanced > branch id i set $

      {JOB_NAME} as branch id.

      result:
      - in sonar: a project is created wiht the given job name (good)
      - in jenkins: the link on the project page links to ${JOB_NAME}

      rather than the resolved value, which leads into a page not found on sonar

      expected result: link in jenkins is valid

        Issue Links

          Activity

          Rob Hamilton added a comment -

          This is not a duplicate of SONARPLUGINS-562. Simply putting $

          {JOB_NAME}

          into the sonar branch id field in Jenkins results in the link:

          http://sonar/project/index/maven:example:%24%7BJOB_NAME%7D

          meaning this field is not resolve global paramters.

          Fabrice Bellingard added a comment -

          I'm reopening this issue as we should consider all the different cases (Maven job or Sonar Runner build step).

          Julien HENRY added a comment -

          I think this issue can be closed and all the efforts should go to SONARPLUGINS-2814

          Fabrice Bellingard added a comment - - edited

          Tested.


            People

            • Assignee:
              Julien HENRY
              Reporter:
              Kerstin Klein
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: