SonarQube Java
  1. SonarQube Java
  2. SONARJAVA-51

Files not ending with '.java' or '.jav' should not be taken into account

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      2

      Description

      Log is attached.
      Hello.java => taken into account as expected
      Hello.notjava => taken into account but shouldn't be
      Hello.notjavazz => not taken into account as expected

        Activity

        Evgeny Mandrikov added a comment -

        SONARJAVA-51.zip can be used to reproduce this issue.

        Evgeny Mandrikov added a comment -

        Fix has been done on Sonar side (https://github.com/SonarSource/sonar/commit/120adee0839a6acd952bb2b0136a434ac90a337a), because Java language defined in sonar-plugin-api.
        Also should be noted that same problem may exist in other plugins (like JavaScript - SONARPLUGINS-2666).

        Freddy Mallet added a comment -

        Manually tested!


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            David Racodon
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: