SonarQube Java
  1. SonarQube Java
  2. SONARJAVA-228

Rule: Boolean expression should not be too complex

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4
    • Component/s: Rules
    • Labels:
      None
    • Number of attachments :
      0

      Activity

      Dinesh Bolkensteyn added a comment -

      Done

      Just as the function's complexity, it also takes into account annonymous classes.

      Dinesh Bolkensteyn added a comment -

      14 issues on Sonar, using the default parameter of 3.

      Fabrice Bellingard added a comment -

      Some feedback with anonymous classes:

      • the issue is not reported on the correct place (see org.sonar.api.measures.MeasuresFilters)
      • some issue should not be reported (see org.sonar.plugins.core.issue.tracking.StringTextComparator)
      Dinesh Bolkensteyn added a comment -

      That's now fixed!

      Fabrice Bellingard added a comment -

      Tested!


        People

        • Assignee:
          Dinesh Bolkensteyn
          Reporter:
          Dinesh Bolkensteyn
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: