SonarQube Java
  1. SonarQube Java
  2. SONARJAVA-21

When a timeout exception occurs while executing Findbugs, the timeout threshold value should be logged

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2
    • Component/s: Findbugs
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The following stack trace is generated :

      Caused by: org.sonar.api.utils.SonarException: Can not execute Findbugs
      	at org.sonar.plugins.findbugs.FindbugsExecutor.execute(FindbugsExecutor.java:145)
      	at org.sonar.plugins.findbugs.FindbugsSensor.analyse(FindbugsSensor.java:64)
      	at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:64)
      	at org.sonar.batch.phases.Phases.execute(Phases.java:91)
      	at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:125)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:69)
      	at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:141)
      	at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:131)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:69)
      	at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:83)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:69)
      	at org.sonar.batch.Batch.execute(Batch.java:104)
      	at org.sonar.runner.internal.batch.Launcher.executeBatch(Launcher.java:69)
      	at org.sonar.runner.internal.batch.Launcher.execute(Launcher.java:61)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.sonar.runner.Runner.delegateExecution(Runner.java:285)
      	... 3 more
      Caused by: java.util.concurrent.TimeoutException
      	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:228)
      	at java.util.concurrent.FutureTask.get(FutureTask.java:91)
      	at org.sonar.plugins.findbugs.FindbugsExecutor.execute(FindbugsExecutor.java:139)
      	... 21 more
      

      I expect to get :

      Caused by: org.sonar.api.utils.SonarException: Can not execute Findbugs with a timeout threshold value of 600000 milliseconds
      	at org.sonar.plugins.findbugs.FindbugsExecutor.execute(FindbugsExecutor.java:145)
      	at org.sonar.plugins.findbugs.FindbugsSensor.analyse(FindbugsSensor.java:64)
      	at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:64)
      	at org.sonar.batch.phases.Phases.execute(Phases.java:91)
      	at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:125)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:69)
      	at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:141)
      	at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:131)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:69)
      	at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:83)
      	at org.sonar.batch.bootstrap.Module.start(Module.java:69)
      	at org.sonar.batch.Batch.execute(Batch.java:104)
      	at org.sonar.runner.internal.batch.Launcher.executeBatch(Launcher.java:69)
      	at org.sonar.runner.internal.batch.Launcher.execute(Launcher.java:61)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.sonar.runner.Runner.delegateExecution(Runner.java:285)
      	... 3 more
      Caused by: java.util.concurrent.TimeoutException
      	at java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:228)
      	at java.util.concurrent.FutureTask.get(FutureTask.java:91)
      	at org.sonar.plugins.findbugs.FindbugsExecutor.execute(FindbugsExecutor.java:139)
      	... 21 more
      

        Activity

        Freddy Mallet added a comment -

        Manually tested !


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Freddy Mallet
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: