SonarQube Java
  1. SonarQube Java
  2. SONARJAVA-178

The INFO message "No information about coverage per test." is misleading

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4
    • Component/s: JaCoCo
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Some Sonar users misunderstand this message and believe that Sonar is not able to extract the unit test coverage from the jacoco report.

      I would replace this message by :

      • Code coverage available (coverages relating to each unit test not provided)

        Activity

        Dinesh Bolkensteyn added a comment -

        Done

        Dinesh Bolkensteyn added a comment -

        Fabrice found out that the message was actually pretty good, but it was also displayed when no coverage was available, for example when the report did not exist.

        That was the cause of the misunderstandings.

        So, as discussed, I will not update the message, but just make sure that it gets printed only when it should.

        Dinesh Bolkensteyn added a comment -

        Well spotted Fabrice, it should now be fixed.

        I let you test again and let me know if it now makes more sense.

        Fabrice Bellingard added a comment -

        Tested!

        Dinesh Bolkensteyn added a comment -

        Great!


          People

          • Assignee:
            Dinesh Bolkensteyn
            Reporter:
            Freddy Mallet
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: