SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-364

java.lang.StringIndexOutOfBoundsException when associating projects

    Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.2
    • Component/s: Violations View
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Got this error while re-associating my project with Nemo.

      Stack trace:

      java.lang.StringIndexOutOfBoundsException: String index out of range: -1
      	at java.lang.String.substring(String.java:1937)
      	at java.lang.String.substring(String.java:1904)
      	at org.sonar.ide.eclipse.core.internal.resources.ResourceUtils.findResource(ResourceUtils.java:100)
      	at org.sonar.ide.eclipse.ui.internal.jobs.RefreshAllViolationsJob.doRefreshViolation(RefreshAllViolationsJob.java:94)
      	at org.sonar.ide.eclipse.ui.internal.jobs.RefreshAllViolationsJob.visit(RefreshAllViolationsJob.java:74)
      	at org.eclipse.core.internal.resources.Resource$2.visit(Resource.java:126)
      	at org.eclipse.core.internal.resources.Resource$1.visitElement(Resource.java:85)
      	at org.eclipse.core.internal.watson.ElementTreeIterator.doIteration(ElementTreeIterator.java:82)
      	at org.eclipse.core.internal.watson.ElementTreeIterator.iterate(ElementTreeIterator.java:127)
      	at org.eclipse.core.internal.resources.Resource.accept(Resource.java:95)
      	at org.eclipse.core.internal.resources.Resource.accept(Resource.java:52)
      	at org.eclipse.core.internal.resources.Resource.accept(Resource.java:124)
      	at org.eclipse.core.internal.resources.Resource.accept(Resource.java:108)
      	at org.sonar.ide.eclipse.ui.internal.jobs.RefreshViolationsJob.run(RefreshViolationsJob.java:82)
      	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
      
      

        Activity

        Julien HENRY added a comment -

        The problem could be reproduced when there was a violation on a project itself. Should be fixed now.

        Fabrice Bellingard added a comment -

        Could not reproduce it, so seems to be fixed!
        Tested.

        Julien HENRY added a comment -

        No need for ITs


          People

          • Assignee:
            Julien HENRY
            Reporter:
            Fabrice Bellingard
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: