SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-358

When there are many libraries required by a particular project, an IOException occurs when attempting to start local analysis

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.1.1
    • Component/s: Local Mode
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Steps to reproduce:

      1. Have a project setup that depends on a lot of libraries (common for OSGi projects that use a target platform of ~ 500 bundles)
      2. Configure that project to have a Mode of "Local"
      3. Run the Local Analysis

      Expected Outcome:
      The analysis correctly runs

      Actual Outcome:
      An IOException occurs due to the command line parameter "sonar.libraries" being too long

      The "sonar.libraries" command line parameter is not necessarily the only parameter that can cause this issue - other ones such as "sonar.sources" or "sonar.binaries" could potentially also cause this issue, given that there is no guarantee on maximum size for these.

      The value being passed for the "sonar.libraries" for our use case is attached in sources.txt

        Issue Links

          Activity

          Julien HENRY added a comment -

          Should be fixed by the use of Sonar Runner API 2.2

          Fabrice Bellingard added a comment -

          Let's assume this is fixed thanks to Sonar Runner 2.2.


            People

            • Assignee:
              Julien HENRY
              Reporter:
              Kayne Barclay
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: