SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-336

Add a new "Change project association" item in the "Sonar" project menu

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: Configuration
    • Labels:
      None
    • Number of attachments :
      0

      Description

      This new item should allow to reopen the association window on the selected projects to update the current association.

        Activity

        Freddy Mallet added a comment -

        Works well Julien !

        I only got this following exception one time when playing with this "Change project association" menu but I'm not able to reproduce it :

        java.lang.NullPointerException
        	at org.sonar.ide.eclipse.m2e.SonarProjectConfigurator$SonarMavenInfos.<init>(SonarProjectConfigurator.java:80)
        	at org.sonar.ide.eclipse.m2e.SonarProjectConfigurator.mavenProjectChanged(SonarProjectConfigurator.java:58)
        	at org.eclipse.m2e.core.internal.project.ProjectConfigurationManager.mavenProjectChanged(ProjectConfigurationManager.java:888)
        	at org.eclipse.m2e.core.internal.project.registry.ProjectRegistryManager.notifyProjectChangeListeners(ProjectRegistryManager.java:729)
        	at org.eclipse.m2e.core.internal.project.registry.ProjectRegistryManager.applyMutableProjectRegistry(ProjectRegistryManager.java:852)
        	at org.eclipse.m2e.core.internal.project.registry.ProjectRegistryManager.refresh(ProjectRegistryManager.java:281)
        	at org.eclipse.m2e.core.internal.project.registry.MavenProjectManager.refresh(MavenProjectManager.java:58)
        	at org.eclipse.m2e.core.internal.builder.MavenBuilder.build(MavenBuilder.java:87)
        	at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:199)
        	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:239)
        	at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:295)
        	at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:351)
        	at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
        	at org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:143)
        	at org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
        	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
        
        Julien HENRY added a comment -

        This is related to SONARIDE-316 and I don't think there is a relation with this ticket. I was using a m2e API that can return null when Maven model is not yet loaded (for example just after starting Eclipse). It explains why it is hard to reproduce.

        Now I am using an API that will wait until Maven model is ready.

        Good catch!

        Freddy Mallet added a comment -

        Well done !

        Julien HENRY added a comment -

        IT added


          People

          • Assignee:
            Julien HENRY
            Reporter:
            Freddy Mallet
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: