SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-293

Sonar Eclipse Plugin misses out on certain Findbugs Rules

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      we recently found that the sonar eclipse plugin does not correctly pull the complete activated rule set from the server: the server showed us rule markers which the plugin didn't, and after comparing the local rulse set xml created and used by the plugin against the rule set xml that the server creates via "permalinks", the local profile is missing rules that are activated on the server.

      e.g. the following rule is activated on our server and creating warnings, whereas the local sonar plugin does not create those warnings after a local analysis:

      Findbugs-Warning "Bad practice - Equals checks for noncompatible operand"

      we could break the problem downn to telling that it concerns:

      • only findbugs rules
      • but not all findbugs rules
      • it is not linked to a certain profile
      • it is not linked to a severity level

        Issue Links

          Activity

          Kevin Daly added a comment -

          We are also having this issue.. Anything we can do to help get this fix let me know.

          Alex Lorenz added a comment -

          first of all, you could vote for it. ;D

          then, if you can provide information that is more specific - or different - from the symptoms we already analyzed, feel free to add it.

          thanks!

          Gustavo Labbate Godoy added a comment -

          we have the same problem.
          When we use the eclipse plugin, some violations aren't listed in measures view. As example, we have 312 major violations and 1 minor violation in a class, and the same class, in server, have 643 violation (272 major and 360 minor).

          thanks

          Freddy Mallet added a comment -

          We know what the problem is : the Sonar Eclipse plugin embeds version 2.8 of the Sonar Findbugs plugin and not the one of the Sonar server.

          Kevin Daly added a comment -

          Would this not be an easy fix? Is there any way for us to fix it and contribute it?

          Julien HENRY added a comment -

          Will be automatically solved when we will use Sonar Runner

          Freddy Mallet added a comment -

          Manually tested!


            People

            • Assignee:
              Julien HENRY
              Reporter:
              Alex Lorenz
            • Votes:
              4 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: