SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-222

NPE when using a proxy and bad Sonar server URL

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.4
    • Component/s: None
    • Labels:
      None
    • Environment:
      Eclipse 3.5.2
    • Number of attachments :
      0

      Description

      I have a proxy server configured in Eclipse (manual proxy). This proxy is supposed to not be used for internal URL (say *.acme.com).
      Then I did a mistake when entering Sonar server URL. I typed:
      http:/sonar.acme.com:9000/sonar
      (missing '/').

      As a result Sonar IDE was not able to access remote Sonar server and failed with a NPE.

      !ENTRY org.sonar.ide.eclipse.logback.appenders 4 0 2011-04-11 16:04:54.029
      !MESSAGE Unable to configure proxy for sonar-ws-client
      !STACK 0
      java.lang.NullPointerException
      	at org.eclipse.core.internal.net.ProxyManager.tryGetURI(ProxyManager.java:329)
      	at org.eclipse.core.internal.net.ProxyManager.getProxyDataForHost(ProxyManager.java:306)
      	at org.eclipse.core.internal.net.ProxyManager.getProxyDataForHost(ProxyManager.java:371)
      	at org.sonar.wsclient.internal.WSClientPlugin.selectProxy(WSClientPlugin.java:60)
      	at org.sonar.wsclient.WSClientFactory.configureProxy(WSClientFactory.java:76)
      	at org.sonar.wsclient.WSClientFactory.create(WSClientFactory.java:53)
      	at org.sonar.ide.eclipse.internal.core.ServersManager.getSonar(ServersManager.java:139)
      	at org.sonar.ide.eclipse.internal.ui.wizards.ConfigureProjectsWizard$ConfigureProjectsPage$AssociateProjects.run(ConfigureProjectsWizard.java:327)
      	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)
      

        Activity

        David Gageot added a comment -

        Couldn't reproduce the root cause.

        The code asks the proxy for an empty url. It it ever happens again, it won't fail anymore.


          People

          • Assignee:
            Freddy Mallet
            Reporter:
            Julien HENRY
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: