SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-213

Internal error when running local analysis : NoSuchMethodError: org.apache.commons.io.FileUtils.write(Ljava/io/File;Ljava/lang/CharSequence;)V

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      It seems the version of commons-io (1.4) embedded is too old, the method is in commons-io 2.0 only.

      org.picocontainer.PicoLifecycleException: PicoLifecycleException: method 'public void org.sonar.batch.components.EmbedderPhases.start()', instance 'org.sonar.batch.components.EmbedderPhases@f00b24, java.lang.RuntimeException: wrapper
      at org.picocontainer.monitors.NullComponentMonitor.lifecycleInvocationFailed(NullComponentMonitor.java:77)
      at org.picocontainer.lifecycle.ReflectionLifecycleStrategy.monitorAndThrowReflectionLifecycleException(ReflectionLifecycleStrategy.java:132)
      at org.picocontainer.lifecycle.ReflectionLifecycleStrategy.invokeMethod(ReflectionLifecycleStrategy.java:115)
      at org.picocontainer.lifecycle.ReflectionLifecycleStrategy.start(ReflectionLifecycleStrategy.java:89)
      at org.picocontainer.injectors.AbstractInjectionFactory$LifecycleAdapter.start(AbstractInjectionFactory.java:84)
      at org.picocontainer.behaviors.AbstractBehavior.start(AbstractBehavior.java:169)
      at org.picocontainer.behaviors.Stored$RealComponentLifecycle.start(Stored.java:132)
      at org.picocontainer.behaviors.Stored.start(Stored.java:110)
      at org.picocontainer.DefaultPicoContainer.potentiallyStartAdapter(DefaultPicoContainer.java:996)
      at org.picocontainer.DefaultPicoContainer.startAdapters(DefaultPicoContainer.java:989)
      at org.picocontainer.DefaultPicoContainer.start(DefaultPicoContainer.java:746)
      at org.sonar.batch.Module.start(Module.java:88)
      at org.sonar.batch.SonarEclipseRuntime.analyse(SonarEclipseRuntime.java:51)
      at org.sonar.ide.eclipse.core.jobs.AnalyseProjectJob.run(AnalyseProjectJob.java:98)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: java.lang.RuntimeException: wrapper
      at org.picocontainer.lifecycle.ReflectionLifecycleStrategy.monitorAndThrowReflectionLifecycleException(ReflectionLifecycleStrategy.java:130)
      ... 13 more
      Caused by: java.lang.NoSuchMethodError: org.apache.commons.io.FileUtils.write(Ljava/io/File;Ljava/lang/CharSequence;)V
      at org.sonar.plugins.pmd.PmdExecutor.writeXmlReport(PmdExecutor.java:140)
      at org.sonar.plugins.pmd.PmdExecutor.execute(PmdExecutor.java:83)
      at org.sonar.plugins.pmd.PmdSensor.analyse(PmdSensor.java:49)
      at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:59)
      at org.sonar.batch.components.EmbedderPhases.start(EmbedderPhases.java:64)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.picocontainer.lifecycle.ReflectionLifecycleStrategy.invokeMethod(ReflectionLifecycleStrategy.java:110)
      ... 12 more

        Activity

        Evgeny Mandrikov added a comment - - edited

        Hi Vincent,

        You're right that this method available only since commons-io 2.0, but we don't embed commons-io, and use bundle from Eclipse Orbit, however we use incorrect version of this bundle. This issue would be fixed before release.


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Vincent Latombe
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: