SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-205

Refactor the way to launch local Sonar analysis (use Sonar Runner and dryRun mode)

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Use Sonar Runner to perform local analysis. In Sonar 3.4 there will be a dryRun mode to perform an analysis without the need to access remote DB.

        Issue Links

          Activity

          Freddy Mallet added a comment -

          Works well julien but could you :

          • Automatically display the Violations view once a local analysis is completed ?
          • When an issue occurs during local analysis, the message should be "Check Eclipse console for details" instead of "Check Sonar console for details"
          • When an Eclipse project P2 has a dependency on another open Eclipse project P1, classes contained by P1 are not found when analysing P2. Which is not the case when project P1 is closed in eclipse.
          Julien HENRY added a comment -
          • Automatically display violation view -> done
          • I keep the console name because it is really its name in Eclipse
          • You last issue is in fact SONARIDE-221
          Freddy Mallet added a comment -

          About the automatic display of the violation view after a local analysis, I don't manage to reproduce this new behavior ?

          Freddy Mallet added a comment -

          Works well Julien, you can forget my last comment !

          Julien HENRY added a comment -

          IT added


            People

            • Assignee:
              Julien HENRY
              Reporter:
              Evgeny Mandrikov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: