Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

        Issue Links

          Activity

          Hide
          Jörg Hohwiller added a comment -

          In case you guyz care:
          The solution is not properly correct. If I setup an eclipse Luna SR1 with latest m2e, STS and sonar-ide then I end up with two bundles for slf4j:

          • slf4j.api_1.7.2.jar
          • org.slf4j.api_1.7.2.v20121108-1250.jar

          This is breaking m2e with this error:

          java.lang.IncompatibleClassChangeError: Class ch.qos.logback.classic.LoggerContext does not implement the requested interface org.slf4j.ILoggerFactory

          Removing slf4j.api_1.7.2.jar fixes m2e but causes

          org.osgi.framework.BundleException: Could not resolve module: org.sonar.ide.eclipse.wsclient [893]
          Unresolved requirement: Require-Bundle: slf4j.api; bundle-version="1.6.6"

          The problem is that plugin vendors like sonar-ide, m2e or STS have to talk with each other.
          However sometimes they just do not care and end-users are left in trouble:
          https://bugs.eclipse.org/bugs/show_bug.cgi?id=438161

          Show
          Jörg Hohwiller added a comment - In case you guyz care: The solution is not properly correct. If I setup an eclipse Luna SR1 with latest m2e, STS and sonar-ide then I end up with two bundles for slf4j: slf4j.api_1.7.2.jar org.slf4j.api_1.7.2.v20121108-1250.jar This is breaking m2e with this error: java.lang.IncompatibleClassChangeError: Class ch.qos.logback.classic.LoggerContext does not implement the requested interface org.slf4j.ILoggerFactory Removing slf4j.api_1.7.2.jar fixes m2e but causes org.osgi.framework.BundleException: Could not resolve module: org.sonar.ide.eclipse.wsclient [893] Unresolved requirement: Require-Bundle: slf4j.api; bundle-version="1.6.6" The problem is that plugin vendors like sonar-ide, m2e or STS have to talk with each other. However sometimes they just do not care and end-users are left in trouble: https://bugs.eclipse.org/bugs/show_bug.cgi?id=438161
          Hide
          Fred Bricon added a comment -

          The Require-Bundle should now be org.slf4j.api instead of slf4j.api

          Show
          Fred Bricon added a comment - The Require-Bundle should now be org.slf4j.api instead of slf4j.api
          Show
          Julien HENRY added a comment - See https://jira.codehaus.org/browse/SONARIDE-434
          Hide
          Jörg Hohwiller added a comment -

          Awesome. Thanks for taking care. Sonar source and community actually care about quality

          Show
          Jörg Hohwiller added a comment - Awesome. Thanks for taking care. Sonar source and community actually care about quality

            People

            • Assignee:
              Evgeny Mandrikov
              Reporter:
              Evgeny Mandrikov
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: