SonarQube Eclipse
  1. SonarQube Eclipse
  2. SONARIDE-122

Sonar server configured to force user authentication, but test connection always successful

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.4
    • Component/s: Configuration
    • Labels:
      None
    • Number of attachments :
      0

      Issue Links

        Activity

        Hide
        Evgeny Mandrikov added a comment -

        As a workaround: if credentials not valid, then users can't get list of his properties (/api/user_properties).

        Show
        Evgeny Mandrikov added a comment - As a workaround: if credentials not valid, then users can't get list of his properties (/api/user_properties).
        Hide
        David Gageot added a comment -

        The wizard needs to answer three questions:
        + Is the provided url ok?
        + Does the sonar server asks for a login/password?
        + Are the login/password ok?

        We currently need three queries to check that. I'm creating a ticket to improve Sonar WS Api

        Show
        David Gageot added a comment - The wizard needs to answer three questions: + Is the provided url ok? + Does the sonar server asks for a login/password? + Are the login/password ok? We currently need three queries to check that. I'm creating a ticket to improve Sonar WS Api
        Hide
        Freddy Mallet added a comment -

        Manually tested !

        Show
        Freddy Mallet added a comment - Manually tested !

          People

          • Assignee:
            David Gageot
            Reporter:
            Evgeny Mandrikov
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: