SonarQube C#
  1. SonarQube C#
  2. SONARCS-93

Gendarme sensor crashes with skipped modules

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows XP Pro - Maven 2.1.0 - Java JDK 6.0u23 - Sonar 2.8 - .NET Framework 4.0
    • Number of attachments :
      1

      Description

      If your pom.xml project contains excluded modules, gendarme sensor crashes as it is unable to find the gendarme report for the excluded module.

      To reproduce the bug, you can use the attached .NET 4.0 solution. This solution is compound of 3 projects : SonarTestMain, SonarTestIncluded and SonarTestExcluded. Only SonarTestExcluded has been excluded from analysis using <sonar.skippedModules /> directive in pom.xml.

      When you run mvn compile and mvn sonar:sonar, you get the following fatal error :

      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error while parsing gendarme report
      C:\Projects\SonarTestMain\target\gendarme-report-SonarTestExcluded.xml (The system cannot find the file specified)
      [INFO] ------------------------------------------------------------------------

        Activity

        Clemens Eberwein added a comment -

        Same problem here but i found a workaround:

        1) comment the skippedProjects settings in the pom file
        2) run mvn dotnet:gendarme
        3) add "skip projects" again and set "sonar.dotnet.gendarme" to "reuseReport" ("reuse" works too)

        Julien HENRY added a comment -

        This bug was solved since Gendarme plugin was reworked and is now executed once for each module and correctly skipped if required.


          People

          • Assignee:
            Julien HENRY
            Reporter:
            Anonymous
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: