SonarQube C#
  1. SonarQube C#
  2. SONARCS-84

NPE exceptions are raised when bad file patterns are used

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: .Net Core
    • Labels:
      None
    • Number of attachments :
      0

      Description

      When properties such as sonar.dotnet.test.assemblies are cincorrectly set, NPE may be raised (if too many '..' are used...). Below the logs that the user may get. A clean error message might be much better.

      [exec] Caused by: java.lang.NullPointerException
      [exec] at org.sonar.dotnet.tools.commons.utils.FileFinder.findFiles(FileFinder.java:177)
      [exec] at org.sonar.dotnet.tools.commons.utils.FileFinder.findFiles(FileFinder.java:123)
      [exec] at org.sonar.plugins.csharp.gallio.GallioSensor.findTestAssemblies(GallioSensor.java:122)
      [exec] at org.sonar.plugins.csharp.gallio.GallioSensor.executeRunner(GallioSensor.java:170)
      [exec] at org.sonar.plugins.csharp.gallio.GallioSensor.analyse(GallioSensor.java:153)

        Activity

        Fabrice Bellingard added a comment -

        Tested.


          People

          • Assignee:
            Alexandre Victoor
            Reporter:
            Alexandre Victoor
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: