SonarQube C#
  1. SonarQube C#
  2. SONARCS-187

Parsing error on a Gallio result file

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 1.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The Gallio result file http://old.nabble.com/file/p32242733/gallio-report.xml can't be parsed, giving the following parsing error:

      [16:29:08]: [Step 2/2] Exception in thread "main" org.sonar.batch.bootstrapper.BootstrapException: org.sonar.api.utils.SonarException: Error while trying to get the next element name
      [16:29:08]: [Step 2/2] 	at org.sonar.runner.Runner.delegateExecution(Runner.java:155)
      [16:29:08]: [Step 2/2] 	at org.sonar.runner.Runner.execute(Runner.java:58)
      [16:29:08]: [Step 2/2] 	at org.sonar.runner.Main.main(Main.java:52)
      [16:29:08]: [Step 2/2] Caused by: org.sonar.api.utils.SonarException: Error while trying to get the next element name
      [16:29:08]: [Step 2/2] 	at org.sonar.plugins.csharp.gallio.helper.StaxHelper.findNextElementName(StaxHelper.java:156)
      [16:29:08]: [Step 2/2] 	at org.sonar.plugins.csharp.gallio.results.coverage.PartCoverParsingStrategy.findFiles(PartCoverParsingStrategy.java:56)
      [16:29:08]: [Step 2/2] 	at org.sonar.plugins.csharp.gallio.results.coverage.CoverageResultParser.parse(CoverageResultParser.java:108)
      [16:29:08]: [Step 2/2] 	at org.sonar.plugins.csharp.gallio.CoverageReportSensor.parseAndSaveCoverageResults(CoverageReportSensor.java:112)
      [16:29:08]: [Step 2/2] 	at org.sonar.plugins.csharp.gallio.CoverageReportSensor.analyse(CoverageReportSensor.java:107)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.phases.SensorsExecutor.execute(SensorsExecutor.java:63)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.phases.Phases.execute(Phases.java:93)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.ProjectModule.doStart(ProjectModule.java:145)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.Module.start(Module.java:89)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:106)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.BatchModule.analyze(BatchModule.java:101)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.BatchModule.doStart(BatchModule.java:96)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.Module.start(Module.java:89)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.BootstrapModule.doStart(BootstrapModule.java:96)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.bootstrap.Module.start(Module.java:89)
      [16:29:08]: [Step 2/2] 	at org.sonar.batch.Batch.execute(Batch.java:74)
      [16:29:08]: [Step 2/2] 	at org.sonar.runner.Launcher.executeBatch(Launcher.java:60)
      [16:29:08]: [Step 2/2] 	at org.sonar.runner.Launcher.execute(Launcher.java:53)
      [16:29:08]: [Step 2/2] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [16:29:08]: [Step 2/2] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [16:29:08]: [Step 2/2] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [16:29:08]: [Step 2/2] 	at java.lang.reflect.Method.invoke(Method.java:597)
      [16:29:08]: [Step 2/2] 	at org.sonar.runner.Runner.delegateExecution(Runner.java:152)
      [16:29:08]: [Step 2/2] 	... 2 more
      [16:29:08]: [Step 2/2] Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,75]
      [16:29:08]: [Step 2/2] Message: Can not call 'getLocalName(): cursor does not point to a valid node (curr event [null]; cursor state CLOSED)
      [16:29:08]: [Step 2/2] 	at org.codehaus.staxmate.in.SMInputCursor.constructStreamException(SMInputCursor.java:1855)
      [16:29:08]: [Step 2/2] 	at org.codehaus.staxmate.in.CursorBase._notAccessible(CursorBase.java:296)
      [16:29:08]: [Step 2/2] 	at org.codehaus.staxmate.in.SMInputCursor.getLocalName(SMInputCursor.java:587)
      [16:29:08]: [Step 2/2] 	at org.sonar.plugins.csharp.gallio.helper.StaxHelper.findNextElementName(StaxHelper.java:154)
      [16:29:08]: [Step 2/2] 	... 24 more
      [16:29:08]: [Step 2/2] Process exited with code 1
      

        Activity

        Alexandre Victoor added a comment -

        This issue seems to be fixed already


          People

          • Assignee:
            Alexandre Victoor
            Reporter:
            Fabrice Bellingard
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: