SonarQube C#
  1. SonarQube C#
  2. SONARCS-170

FxCop crash when assemblies are located on another drive

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: FxCop
    • Labels:
      None
    • Number of attachments :
      0

      Description

      As of version 1.4, sonar fxcop plugin cannot be used if the generated assemblies are located on a drive different from teh one where the source files are located. We get a warning message from FxCop:

       If using a shared project, all files must be on the same drive so that they can be referenced by relative paths
      

      The problem is fixed a SharedProject element is added in the FxCop xml configuration file as below:

      <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
      <FxCopProject Version="1.36">
          <ProjectOptions>
              <SharedProject>True</SharedProject>
              <SaveMessages>
      

        Activity

        Fabrice Bellingard added a comment -

        Tested.


          People

          • Assignee:
            Alexandre Victoor
            Reporter:
            Alexandre Victoor
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: