SonarQube
  1. SonarQube
  2. SONAR-377

sonar maven 1.4.1 plugin does not work on maven 2.1-m1 and maven 2.0.10-x

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.1, 1.4.2, 1.4.3, 1.5
    • Fix Version/s: 1.8
    • Component/s: Maven Plugin
    • Labels:
      None
    • Number of attachments :
      0

      Description

      See also http://www.nabble.com/sonar-plugin-in-freestyle-maven2-project-exception-tt19668939.html

      [INFO] [sonar:sonar]
      
      [ERROR] Cannot execute the command test-compile
      org.apache.maven.lifecycle.LifecycleExecutionException: Unable to initialise extensions
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:200)
      
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:179)
      	at ch.hortis.sonar.mvn.SonarMavenEmbedder.execute(SonarMavenEmbedder.java:151)
      	at ch.hortis.sonar.mvn.SonarMojo.executeMaven(SonarMojo.java:248)
      
      	at ch.hortis.sonar.mvn.SonarMojo.executeGoals(SonarMojo.java:231)
      	at ch.hortis.sonar.mvn.SonarMojo.execute(SonarMojo.java:116)
      	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:458)
      
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:676)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:551)
      
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:521)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:369)
      
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:266)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:302)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:585)
      	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      
      	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.codehaus.plexus.PlexusContainerException: Error starting container
      
      	at org.codehaus.plexus.DefaultPlexusContainer.start(DefaultPlexusContainer.java:795)
      	at org.apache.maven.extension.DefaultExtensionManager.createContainer(DefaultExtensionManager.java:255)
      	at org.apache.maven.extension.DefaultExtensionManager.addExtension(DefaultExtensionManager.java:184)
      
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:196)
      	... 23 more
      Caused by: org.codehaus.plexus.component.repository.exception.ComponentRepositoryException: Component descriptor role: 'org.apache.maven.wagon.CommandExecutor', implementation: 'org.apache.maven.wagon.providers.ssh.external.ScpExternalCommandExecutor', role hint: 'scpexe' has a hint, but there are other implementations that don't
      
      	at org.codehaus.plexus.component.repository.DefaultComponentRepository.addComponentDescriptor(DefaultComponentRepository.java:184)
      	at org.codehaus.plexus.DefaultPlexusContainer.addComponentDescriptor(DefaultPlexusContainer.java:515)
      
      	at org.codehaus.plexus.DefaultPlexusContainer.discoverComponents(DefaultPlexusContainer.java:738)
      	at org.codehaus.plexus.DefaultPlexusContainer.start(DefaultPlexusContainer.java:779)
      	... 26 more
      [INFO] ------------------------------------------------------------------------
      
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Cannot execute the command test-compile
      
      Embedded error: Unable to initialise extensions
      Component descriptor role: 'org.apache.maven.wagon.CommandExecutor', implementation: 'org.apache.maven.wagon.providers.ssh.external.ScpExternalCommandExecutor', role hint: 'scpexe' has a hint, but there are other implementations that don't
      
      [INFO] ------------------------------------------------------------------------
      [INFO] For more information, run Maven with the -e switch
      [INFO] ------------------------------------------------------------------------
      

        Issue Links

          Activity

          Simon Brandhof added a comment -

          Thank you Jorg for the test.
          This is not an hudson bug. The problem comes from the sonar maven plugin, so I change the issue title.

          Jorg Heymans added a comment -

          Any chance that this will get fixed in one of the 1.5 milestone releases ?

          Simon Brandhof added a comment -

          Hi Jorg,
          Unfortunatly it is not planned on 1.5, but we have some maven limitations (including this one) that we're going to fix as soon as possible. It will probably be released on a 1.5.x patch or on 1.6.
          Regards

          Jörg Prante added a comment -

          1.7 still fails.

          mvn --version
          Maven version: 2.1.0-M1-RC17
          Java version: 1.6.0_13
          Default locale: de_DE, platform encoding: UTF-8
          OS name: "linux" version: "2.6.18-92.el5" arch: "i386" family: "unix"

          Is there a workaround?

          Simon Brandhof added a comment -

          Hi Jörg,
          1.7 still fails because it's fixed in 1.8 ;o)
          We should release this version next week.

          Jörg Prante added a comment -

          I think it's a Maven 2.1.0-M1-RC17 issue. With enforcing wagon-ssh 1.0-beta-5 in my pom.xml, instead of beta-2, the error disappears.

          pom.xml:

          <build>
          <extensions>
          <extension>
          <groupId>org.apache.maven.wagon</groupId>
          <artifactId>wagon-ssh</artifactId>
          <version><!-1.0-beta-2->1.0-beta-5</version>
          </extension>
          </extensions>
          </build>

          Thank you.


            People

            • Assignee:
              Simon Brandhof
              Reporter:
              Jorg Heymans
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: