SonarQube
  1. SonarQube
  2. SONAR-2753

LCOM4 and PTI metrics are not calculated when running Sonar Analysis with ANT.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Environment:
      Windows XP, Sonar 2.9, Ant 1.7.1, Maven 2.2.1, Jdk1.5.0_17.
    • Number of attachments :
      0

      Description

      Hi All.

      I am using Sonar / Ant / Maven with a huge number of projects, some of them are Maven based and others Ant based.

      The problem is, when I run the Sonar Analysis with Ant, LCOM4 and PTI Metrics are not calculated, however, when run Sonar Analysis with Maven we got this two metrics calculated and showed on Sonar Dashboard.

      I have tried with this properties:
      <property name="sonar.dynamicAnalysis" value="true" />
      <property name="sonar.skipDesign" value="false" />

      bot none of them has any impact regarding to those metrics.

      I have no exceptions during Sonar Analysis.

      Any Idea?

        Activity

        Freddy Mallet added a comment -

        PLEASE do not create any JIRA ticket before having first discussed your issue on the Sonar mailing list. In your case, some metrics like LCOM4 are not computed because looks like you haven't provided the path to the java bytecode (see sonar.binaries property).


          People

          • Assignee:
            Unassigned
            Reporter:
            JC Castillo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: