SonarQube
  1. SonarQube
  2. SONAR-2726

Do not allow upgrade with Derby embedded database

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.12
    • Component/s: Database
    • Labels:
    • Number of attachments :
      0

      Description

      Indeed Derby should not be used in production.

        Issue Links

          Activity

          Hide
          Simon Brandhof added a comment -

          As a reminder there are two ways to upgrade database :

          • POST /setup/setup_database (this is the form in webapp)
          • POST /api/server/setup
          Show
          Simon Brandhof added a comment - As a reminder there are two ways to upgrade database : POST /setup/setup_database (this is the form in webapp) POST /api/server/setup
          Hide
          Evgeny Mandrikov added a comment -

          Tested (to verify DB was copied from 2.10 into 2.12-SNAPSHOT).

          Show
          Evgeny Mandrikov added a comment - Tested (to verify DB was copied from 2.10 into 2.12-SNAPSHOT).

            People

            • Assignee:
              Simon Brandhof
              Reporter:
              Freddy Mallet
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: