SonarQube
  1. SonarQube
  2. SONAR-2424

Possible NPE during export of profile

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.8
    • Fix Version/s: 3.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      2011.05.11 20:46:55 ERROR rails  
      NativeException (java.lang.NullPointerException: null):
        org/sonar/server/ui/JRubyFacade.java:216:in `getProfileExporterMimeType'
        app/controllers/profiles_controller.rb:185:in `export'
        org/jruby/RubyKernel.java:2052:in `send'
        org/jruby/RubyKernel.java:2064:in `send'
        org/jruby/RubyProc.java:268:in `call'
        org/jruby/RubyProc.java:228:in `call'
        file:lib/jruby-rack-1.0.0.1.jar!/vendor/rack-1.2.1/rack/head.rb:9:in `call'
        file:lib/jruby-rack-1.0.0.1.jar!/vendor/rack-1.2.1/rack/methodoverride.rb:24:in `call'
        file:lib/jruby-rack-1.0.0.1.jar!/rack/adapter/rails.rb:36:in `serve_rails'
        file:lib/jruby-rack-1.0.0.1.jar!/rack/adapter/rails.rb:41:in `call'
        file:lib/jruby-rack-1.0.0.1.jar!/jruby/rack/rails.rb:185:in `call'
        file:lib/jruby-rack-1.0.0.1.jar!/rack/handler/servlet.rb:19:in `call'
      
      

        Activity

        Simon Brandhof added a comment -

        Can't reproduce this issue, but error handling has been improved if the requested profile does not exist. A 404 HTTP status is returned in this case.

        Evgeny Mandrikov added a comment -

        I'm not sure if it's the same problem, however with Sonar 2.12-SNAPSHOT :

        2011.11.02 17:32:57 ERROR o.s.s.ui.JRubyFacade  Fail to render: http://localhost:9000/profiles/export?format=ttt&language=java&name=Sonar%2520way
        java.lang.NullPointerException: null
                org/sonar/server/rules/ProfilesConsole.java:114:in `exportProfile'
                org/sonar/server/ui/JRubyFacade.java:216:in `exportProfile'
                /tmp/sonar/tomcat6x/temp/0-ROOT/WEB-INF/app/controllers/profiles_controller.rb:191:in `export'
        
        Freddy Mallet added a comment -

        Evgeny, could you describe how we can reproduce this issue ?
        Thanks

        Evgeny Mandrikov added a comment -

        Freddy, as was shown in comment - this is an export of existing profile using unknown format.

        Evgeny Mandrikov added a comment -

        Fixed in 060d0a4.

        Freddy Mallet added a comment -

        Manually tested

        Evgeny Mandrikov added a comment -

        Closed without integration test.


          People

          • Assignee:
            Evgeny Mandrikov
            Reporter:
            Simon Brandhof
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: