SonarQube
  1. SonarQube
  2. SONAR-1994

Sonar analysis fails when using Maven 2.0.10 or Maven 2.0.11

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.4
    • Fix Version/s: None
    • Component/s: Maven Plugin
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The following error message is displayed :

      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error resolving version for 'org.codehaus.mojo:sonar-maven-plugin': Plugin requires Maven version 3.0
      [INFO] ------------------------------------------------------------------------
      

      This error relates to a limitation of Maven 2.0.10 and Maven 2.0.11 which are not able to automatically downgrade the version of the Sonar plugin to be used.

      To be able to use Sonar with Maven 2.0.10 and 2.0.11, the following lines must be added to the pom.xml file :

        <build>
          <pluginManagement>
            <plugins>
              <plugin>
                <groupId>org.codehaus.mojo</groupId>
                <artifactId>sonar-maven-plugin</artifactId>
                <version>1.0-beta-2</version>
              </plugin>
            </plugins>
          </pluginManagement>
        </build>
      

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Freddy Mallet
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: