SonarQube
  1. SonarQube
  2. SONAR-1534

Activation of all the default FindBugs rules

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.12
    • Fix Version/s: 2.3
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Hi,

      Could you activate all default rules of FindBugs please?

      Some of the FindBugs rules have been deactivated/commented in:
      http://fisheye.codehaus.org/changelog/sonar/?cs=2822

      and the deleted in:
      http://fisheye.codehaus.org/changelog/sonar/?cs=3086

      These rules have been deactivated because they find too many false positive but they should be deactivated in the "Sonar Way with FindBugs" profile instead of deleted them in Sonar.

      We have discussed about this topic in the user ml:
      http://old.nabble.com/How-to-activate-a-standard-FindBugs-rule---ts28263512.html#a28263512

      Thanks in advance.


      Rodolphe Dariol

        Issue Links

          Activity

          Simon Brandhof added a comment -

          All Findbugs rules are automatically activated in the default profile. The problem is that it's currently not trivial to activate only a subset of rules. So I prefer postponing this issue to version 2.3, which will focus on major improvements of rules management.


            People

            • Assignee:
              Freddy Mallet
              Reporter:
              Rodolphe Dariol
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: