SonarQube
  1. SonarQube
  2. SONAR-1439

Findbug failed for one project since 2.0.1 upgrade

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      solaris, jdk 1.6 and mysql database for sonar.
    • Number of attachments :
      1

      Description

      This happened only for one project since 2.0.1 project.
      Here some logs :

      [INFO] [findbugs:findbugs {execution: default-cli}]
      [INFO] Locale is en
           [java] Timeout: killed the sub-process
           [java] 	at org.apache.tools.ant.taskdefs.Java.fork(Java.java:787)
           [java] 	at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:211)
           [java] 	at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:132)
           [java] 	at org.apache.tools.ant.taskdefs.Java.execute(Java.java:105)
           [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
           [java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
           [java] 	at java.lang.reflect.Method.invoke(Method.java:597)
           [java] 	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
           [java] 	at org.apache.tools.ant.Task.perform(Task.java:348)
           [java] 	at groovy.util.AntBuilder.nodeCompleted(AntBuilder.java:199)
           [java] 	at groovy.util.BuilderSupport.doInvokeMethod(BuilderSupport.java:153)
           [java] 	at groovy.util.AntBuilder.doInvokeMethod(AntBuilder.java:149)
           [java] 	at groovy.util.BuilderSupport.invokeMethod(BuilderSupport.java:64)
           [java] 	at org.codehaus.groovy.runtime.InvokerHelper.invokePogoMethod(InvokerHelper.java:784)
           [java] 	at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:758)
           [java] 	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
           [java] 	at org.codehaus.mojo.findbugs.FindBugsMojo.executeFindbugs(FindBugsMojo.groovy:694)
           [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
           [java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
           [java] 	at java.lang.reflect.Method.invoke(Method.java:597)
           [java] 	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
           [java] 	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
           [java] 	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
           [java] 	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
           [java] 	at org.codehaus.mojo.findbugs.FindBugsMojo.executeReport(FindBugsMojo.groovy:523)
           [java] 	at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:98)
           [java] 	at org.apache.maven.reporting.AbstractMavenReport.execute(AbstractMavenReport.java:73)
           [java] 	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:569)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:539)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
           [java] 	at org.sonar.maven2.Maven2PluginExecutor.execute(Maven2PluginExecutor.java:65)
           [java] 	at org.sonar.maven2.Maven2PluginExecutor.execute(Maven2PluginExecutor.java:47)
           [java] 	at org.sonar.batch.SensorsExecutor.executeMavenPlugin(SensorsExecutor.java:69)
           [java] 	at org.sonar.batch.SensorsExecutor.execute(SensorsExecutor.java:55)
           [java] 	at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:54)
           [java] 	at org.sonar.batch.AggregatorBatch.analyzeProject(AggregatorBatch.java:98)
           [java] 	at org.sonar.batch.AggregatorBatch.analyzeProject(AggregatorBatch.java:95)
           [java] 	at org.sonar.batch.AggregatorBatch.analyzeProjects(AggregatorBatch.java:90)
           [java] 	at org.sonar.batch.AggregatorBatch.execute(AggregatorBatch.java:74)
           [java] 	at org.sonar.maven2.BatchMojo.executeBatch(BatchMojo.java:140)
           [java] 	at org.sonar.maven2.BatchMojo.execute(BatchMojo.java:122)
           [java] 	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
           [java] 	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:82)
           [java] 	at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65)
           [java] 	at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:117)
           [java] 	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:569)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:539)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:284)
           [java] 	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
           [java] 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
           [java] 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
           [java] 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
           [java] 	at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
           [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           [java] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
           [java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
           [java] 	at java.lang.reflect.Method.invoke(Method.java:597)
           [java] 	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
           [java] 	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
           [java] 	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
           [java] 	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
           [java] Java Result: -1
      [Fatal Error] :-1:-1: Premature end of file.
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Can not execute Sonar
      
      Embedded error: Can not analyze the project
      Premature end of file.
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Can not execute Sonar
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:569)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:539)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:284)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      	at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Can not execute Sonar
      	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:87)
      	at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65)
      	at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:117)
      	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      	... 17 more
      Caused by: org.apache.maven.plugin.MojoExecutionException: Can not analyze the project
      	at org.sonar.maven2.BatchMojo.executeBatch(BatchMojo.java:143)
      	at org.sonar.maven2.BatchMojo.execute(BatchMojo.java:122)
      	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:82)
      	... 21 more
      Caused by: org.sonar.api.utils.SonarException: Unable to execute maven plugin
      	at org.sonar.maven2.Maven2PluginExecutor.execute(Maven2PluginExecutor.java:68)
      	at org.sonar.maven2.Maven2PluginExecutor.execute(Maven2PluginExecutor.java:47)
      	at org.sonar.batch.SensorsExecutor.executeMavenPlugin(SensorsExecutor.java:69)
      	at org.sonar.batch.SensorsExecutor.execute(SensorsExecutor.java:55)
      	at org.sonar.batch.ProjectBatch.execute(ProjectBatch.java:54)
      	at org.sonar.batch.AggregatorBatch.analyzeProject(AggregatorBatch.java:98)
      	at org.sonar.batch.AggregatorBatch.analyzeProject(AggregatorBatch.java:95)
      	at org.sonar.batch.AggregatorBatch.analyzeProjects(AggregatorBatch.java:90)
      	at org.sonar.batch.AggregatorBatch.execute(AggregatorBatch.java:74)
      	at org.sonar.maven2.BatchMojo.executeBatch(BatchMojo.java:140)
      	... 24 more
      Caused by: org.apache.maven.lifecycle.LifecycleExecutionException: An error has occurred in FindBugs Report report generation.
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:569)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:539)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      	at org.sonar.maven2.Maven2PluginExecutor.execute(Maven2PluginExecutor.java:65)
      	... 33 more
      Caused by: org.apache.maven.plugin.MojoExecutionException: An error has occurred in FindBugs Report report generation.
      	at org.apache.maven.reporting.AbstractMavenReport.execute(AbstractMavenReport.java:79)
      	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      	... 39 more
      Caused by: org.xml.sax.SAXParseException: Premature end of file.
      	at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
      	at groovy.util.XmlSlurper.parse(XmlSlurper.java:117)
      	at groovy.util.XmlSlurper.parse(XmlSlurper.java:136)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
      	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:756)
      	at org.codehaus.groovy.runtime.InvokerHelper.invokePojoMethod(InvokerHelper.java:766)
      	at org.codehaus.groovy.runtime.InvokerHelper.invokeMethod(InvokerHelper.java:754)
      	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodN(ScriptBytecodeAdapter.java:170)
      	at org.codehaus.mojo.findbugs.FindBugsMojo.executeFindbugs(FindBugsMojo.groovy:811)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:86)
      	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:230)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:912)
      	at org.codehaus.groovy.runtime.ScriptBytecodeAdapter.invokeMethodOnCurrentN(ScriptBytecodeAdapter.java:78)
      	at org.codehaus.mojo.findbugs.FindBugsMojo.executeReport(FindBugsMojo.groovy:523)
      	at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:98)
      	at org.apache.maven.reporting.AbstractMavenReport.execute(AbstractMavenReport.java:73)
      	... 41 more
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 29 minutes 30 seconds
      [INFO] Finished at: Fri Mar 12 21:58:42 MET 2010
      [INFO] Final Memory: 90M/431M
      

        Issue Links

          Activity

          Simon Brandhof added a comment -

          Hi Olivier, could you attach the report findbugs.xml please ?

          Olivier Lamy added a comment -

          the problem is I don't have any xml file (see hudson workspace screenshot)

          Simon Brandhof added a comment -

          Strange. Could you check the configuration of the findbugs-maven-plugin in target/sonar/sonar-pom.xml please ?

          Olivier Lamy added a comment -
                <plugin> 
                  <groupId>org.codehaus.mojo</groupId> 
                  <artifactId>findbugs-maven-plugin</artifactId> 
                  <version>2.3.1</version> 
                  <configuration> 
                    <classFilesDirectory>/local/hudson/hudson-slave/workspace/Database On The Web/trunk/dotw-webapp-trans/target/classes</classFilesDirectory> 
                    <xmlOutput>true</xmlOutput> 
                    <threshold>Low</threshold> 
                    <skip>false</skip> 
                    <effort>Default</effort> 
                    <maxHeap>512</maxHeap> 
                    <includeFilterFile>/local/hudson/hudson-slave/workspace/Database On The Web/trunk/dotw-webapp-trans/target/sonar/findbugs-include.xml</includeFilterFile> 
                    <excludeFilterFile>/local/hudson/hudson-slave/workspace/Database On The Web/trunk/dotw-webapp-trans/target/sonar/findbugs-exclude.xml</excludeFilterFile> 
                  </configuration> 
                </plugin> 
          
          Simon Brandhof added a comment -

          Do you reproduce the issue if you execute the findbugs mojo without sonar ?

          Olivier Lamy added a comment -

          nope. weird !

          Simon Brandhof added a comment -

          I don't have many ideas... What's findbugsTemp.xml ? Is findbugs also configured in reports section ?

          Olivier Lamy added a comment -

          So I have a added a configuration for the findbug mojo in my pom with a higher timeout than the default.
          And now it works.

          Simon Brandhof added a comment -

          Ok. Do you think it would be useful to add this timeout parameter in the sonar UI ?
          In every instance I add it to the FAQ.
          Thanks

          Olivier Lamy added a comment -

          why not . could prevent touching all poms

          Adam Karl added a comment -

          I am experiencing this as well and have also been able to run findbugs:findbugs standalone but when doing so within the sonar tasks it hangs.

          Additional information, there is something looking for input on standard in after printing the message "Locale is en". If you hit enter after that, the process continues.

          carsten hellweg added a comment -

          btw, this also happens when using
          linux 2.6, mysql and jdk1.6
          ( not only solaris )

          Freddy Mallet added a comment - - edited

          There is a temporary workaround by specifying the Findbugs "timeout" parameter manually in the pom.xml file :

          <plugin> 
                  <groupId>org.codehaus.mojo</groupId> 
                  <artifactId>findbugs-maven-plugin</artifactId> 
                  <version>2.3.1</version> 
                  <configuration> 
                    <timeout>600000</timeout>       <- 10 minutes by default
                  </configuration> 
          </plugin>
          

          This parameter will be configurable through the Sonar web interface with Sonar 2.1.

          Adam Karl added a comment -

          Does that parameter solve the problem or does it simply make the timeout happen quicker?

          Michal Galet added a comment -

          I have experienced the same problem. The process is killed while doing findbugs analysis on one of the modules. The strange thing is that the findbugs analysis takes ages to complete compared to sonar-1.12.

          Simon Brandhof added a comment -

          Adam, the parameter changes the timeout.
          Michal, this new version of Findbugs is known to be slower. Some of the reasons :

          Simon Brandhof added a comment -

          The timeout parameter is added to the Findbugs plugin. See SONAR-1491.

          Jyothi Prakash Polani added a comment -

          Hi Simon,
          What is the workaround you suggest for an ant application being analyzed in Hudson ?

          Freddy Mallet added a comment -

          Hi Jyothi, this bug is fixed in version 2.1 which should be available in two weeks. Could you wait for Sonar 2.1 ?


            People

            • Assignee:
              Simon Brandhof
              Reporter:
              Olivier Lamy
            • Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: