Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.2
    • Component/s: Maven Plugin
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Executing Sonar with Maven 3.0-alpha-3 fails with the following error :

      [ERROR] Can not execute Sonar: UnsupportedOperationException -> [Help 1]
      org.apache.maven.plugin.MojoExecutionException: Can not execute Sonar
      	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:87)
      	at org.codehaus.mojo.sonar.Bootstraper.start(Bootstraper.java:65)
      	at org.codehaus.mojo.sonar.SonarMojo.execute(SonarMojo.java:117)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:105)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:547)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:317)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:239)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:102)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:421)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:156)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:121)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:592)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: java.lang.UnsupportedOperationException
      	at org.apache.maven.plugin.internal.DefaultPluginManager.executeMojo(DefaultPluginManager.java:107)
      	at org.codehaus.mojo.sonar.Bootstraper.executeMojo(Bootstraper.java:82)
      	... 18 more
      
      

        Issue Links

          Activity

          Linda Cooper added a comment -

          I am seeing this same error with Maven 3.0 Beta.

          Freddy Mallet added a comment -

          I do confirm that the following command line works with maven 3-beta3 :

          mvn org.codehaus.sonar:sonar-maven3-plugin:2.2:sonar
          

          To be able to launch the standard command "mvn sonar:sonar", the ticket MOJO-1545 needs to be fixed.

          Vincent Massol added a comment -

          Hi,

          I'm getting this exact same error. I'm on Sonar 2.2 and Maven 3.0 final. Anything I should do/check? Thanks

          Evgeny Mandrikov added a comment -

          You should use org.codehaus.sonar:sonar-maven3-plugin instead of org.codehaus.mojo:sonar-maven-plugin or see SONAR-1851.

          Vincent Massol added a comment -

          Thanks Evgeny


            People

            • Assignee:
              Simon Brandhof
              Reporter:
              Simon Brandhof
            • Votes:
              19 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: