Maven SCM
  1. Maven SCM
  2. SCM-627

Parsing URL for clone does not match what is passed in with -DconnectionUrl

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      centos5.4
    • Complexity:
      Intermediate
    • Testcase included:
      yes
    • Number of attachments :
      1

      Description

      Mercurial server's hostname name is "hg".

      URL to get to clone a repository is: http://hg/hg/maven

      The SCM plugin seems to treat this URL funny, such that it clones the wrong URL.
      Original ==> Turns into
      http://hg/hg/maven ==> http://hg//maven

      Don't even need a valid Mercurial server to reproduce.

      $ mvn scm:checkout -DconnectionUrl=scm:hg:http://hg/hg/maven
      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building myplugin Maven Plugin 1.0.0-SNAPSHOT
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — maven-scm-plugin:1.5:checkout (default-cli) @ myplugin —
      [INFO] Removing /sandbox/target/checkout
      [INFO] Removing /sandbox/target/checkout
      [INFO] EXECUTING: /bin/sh -c cd /sandbox/target && hg clone -r tip http://hg//maven /sandbox/target/checkout
      [ERROR]
      EXECUTION FAILED

        Activity

        Hubert added a comment -

        Patch to fix the issue.

        It is diffed from tag: maven-scm-1.5

        Hubert added a comment -

        Duplicate of SCM-628, and SCM-628 has the patch attached.


          People

          • Assignee:
            Unassigned
            Reporter:
            Hubert
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: