Maven SCM
  1. Maven SCM
  2. SCM-580

Maven SCM plugin configuration ignored if executions are used.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 1.4
    • Fix Version/s: None
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Windows
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      When utilizing the embedded configuration tag, everything is perfect. However, once I try to use executions, the plugin fails to recognize the settings specified in within the execution tag. Here is the portion of my pom file that doesn't work:

      
      		<profile>
                  <id>bootstrap-all</id>
                  <activation>
                      <activeByDefault>true</activeByDefault>
                  </activation>
      			<build>
      				<plugins>
      					<plugin>
      						<groupId>org.apache.maven.plugins</groupId>
      						<artifactId>maven-scm-plugin</artifactId>
      						<version>1.4</version>
      						<configuration>
      							<skipCheckoutIfExists/>
      						</configuration>
      						<executions>
      							<execution>
      								<id>checkout_a</id>
      								<configuration>
      									<connectionUrl>scm:svn:https://svnserver/svn/prod/java/aws-core-webutils/trunk/</connectionUrl>
      									<checkoutDirectory>${basedir}..\aws-core-webutils</checkoutDirectory>
      								</configuration>
      								<phase>process-resources</phase>
      								<goals>
      									<goal>checkout</goal>
      								</goals>
      							</execution>
      						</executions>
      					</plugin>		
      				</plugins>
      			</build>
      		</profile>
      

      However, this does work:

      		<profile>
                  <id>bootstrap-all</id>
                  <activation>
                      <activeByDefault>true</activeByDefault>
                  </activation>
      			<build>
      				<plugins>
      					<plugin>
      						<groupId>org.apache.maven.plugins</groupId>
      						<artifactId>maven-scm-plugin</artifactId>
      						<version>1.4</version>
      						<configuration>
      							<skipCheckoutIfExists/>
      							<connectionUrl>scm:svn:https://svnserver/svn/prod/java/aws-core-webutils/trunk/</connectionUrl>
      							<checkoutDirectory>${basedir}\..\aws-core-webutils</checkoutDirectory>
      						</configuration>
      					</plugin>		
      				</plugins>
      			</build>
      		</profile>
      

        Activity

        Hide
        Olivier Lamy added a comment -

        which maven version are you using ?

        Show
        Olivier Lamy added a comment - which maven version are you using ?
        Hide
        H.-C. Gürsoy added a comment -

        Dear Lee,

        it's sad but true: it's a maven "feature"

        I've fighted myself with this "feature", see these issues:

        http://jira.codehaus.org/browse/MNG-3425
        http://jira.codehaus.org/browse/MNG-3401

        and

        http://jira.codehaus.org/browse/MSQL-65 (the last one is exactly the same usecase).

        Best regards
        Halil

        Show
        H.-C. Gürsoy added a comment - Dear Lee, it's sad but true: it's a maven "feature" I've fighted myself with this "feature", see these issues: http://jira.codehaus.org/browse/MNG-3425 http://jira.codehaus.org/browse/MNG-3401 and http://jira.codehaus.org/browse/MSQL-65 (the last one is exactly the same usecase). Best regards Halil

          People

          • Assignee:
            Robert Scholte
            Reporter:
            Lee Fox
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: