Maven SCM
  1. Maven SCM
  2. SCM-502

checking out a tag from a remote repository fails if the tag was not on the current branch

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3
    • Component/s: maven-scm-provider-git
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Calling scm:checkout for a tag often results in a merge failure.

      This is caused by the fact that we do a git-pull prior to the checkout, but in fact for tags, we only shall do a git-fetch.

      This is due to the fact that the tag may be on a different branch, so merging this branch into the current branch in the local repository would destroy the local repository.

      Instead we should first do a git-fetch [fetchUrl] followed by a git-checkout tagname.

      This will create a 'detached HEAD' in the local repo which is exactly the way it should be in git.

        Activity

        Mark Struberg added a comment -

        fixed in Revision 823147


          People

          • Assignee:
            Mark Struberg
            Reporter:
            Mark Struberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: