RVM
  1. RVM
  2. RVM-827

Crash in GC while running Eclipse IDE

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: hg tip
    • Fix Version/s: 3.1.1
    • Component/s: Compiler: Baseline
    • Labels:
      None
    • Number of attachments :
      3

      Description

      I get the following error running Eclipse IDE on BaseBaseSemiSpace on ia32-linux.

      Fatal error: ArrayIndexOutOfBoundsException within uninterruptible region (index was 0x1ad0a1e9).
      Died in GC:
      Exiting virtual machine due to uninterruptibility violation.

      Attaching the entire output.

      1. crash-20090818.txt
        23 kB
        Suriya Subramanian
      2. gc-crash-eclipse.txt
        30 kB
        Suriya Subramanian
      3. gc-crash-eclipse-2.txt
        47 kB
        Suriya Subramanian

        Activity

        Suriya Subramanian added a comment -

        Stacktrace output from a different run, also showing a crash during GC.

        Suriya Subramanian added a comment -

        This bug exists with SVN r15768 (currently the HEAD).

        You can reproduce this bug by doing the following on an x86-linux machine.

        wget http://www.cs.utexas.edu/users/suriya/eclipse-crash.tar.gz
        tar -zxvf eclipse-crash.tar.gz
        cd eclipse-crash
        java -cp eclipse/startup.jar -Dosgi.ws=gtk -Dosgi.os=linux -Dosgi.arch=x86 -Dosgi.locking=none org.eclipse.core.launcher.Main -dev -data wk-run
        rvm -cp eclipse/startup.jar -Dosgi.ws=gtk -Dosgi.os=linux -Dosgi.arch=x86 -Dosgi.locking=none org.eclipse.core.launcher.Main -dev -data wk-run

        The application has an infinite loop and does not terminate. With Sun's JVM, the application will print a line to the console after each iteration. The output goes something like this:

        Iteration 0: 2333 (Avg 2333)
        Iteration 1: 1175 (Avg 2217)
        Iteration 2: 1140 (Avg 2109)
        Iteration 3: 1109 (Avg 2009)
        Iteration 4: 1174 (Avg 1926)

        With Jikes RVM, the application crashes even before it can complete the 0th iteration. I am also attaching the output of a failing run.

        Suriya Subramanian added a comment -

        Output from a failed run with BaseBaseSemiSpace_ia32-linux configuration.

        Suriya Subramanian added a comment -

        The application works as expected with Jikes RVM 2.9.3.

        Daniel Frampton added a comment -

        Tried to reproduce exactly as above. Runs with no output and no errors and terminates quickly under both rvm and java.

        Maybe there is something missing from your test or the command you have pasted in is wrong?

        Daniel Frampton added a comment -

        Worked out what was wrong... I needed to have an X display environment around. I assume the error messages are buried somewhere in eclipse...

        Daniel Frampton added a comment -

        Trivial test case for this added in r15769.

        It seems we are not doing the right thing at some point when transitioning in and out of JNI and Java... Will have a quick look but might have to get Fil to look since he wrote the code.

        Daniel Frampton added a comment -

        Fixed in r15770.

        The new unit test and the eclipse test attached both seem to work now.

        Suriya Subramanian added a comment -

        Thank you very much for fixing this bug.


          People

          • Assignee:
            Daniel Frampton
            Reporter:
            Suriya Subramanian
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: