RVM
  1. RVM
  2. RVM-60

invalid argument: NaN at java.math.BigDecimal.<init>(BigDecimal.java:255) on SPECjbb2005

    Details

    • Number of attachments :
      0

      Description

      An intermittent failure occurs on ia32 when the bootimage is opt compiled. The last time it happened was at

      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx64.anu.edu.au/sanity.217/FullAdaptiveMarkCompact/default/SPECjbb2005/SPECjbb2005/Output.txt

      The build configurations it occurs in include; production (x10), FullAdaptiveMarkCompact (x3), FullAdaptiveCopyMS (x7) and FullAdaptiveGenCopy (x2)

      To identify the occasions where this occurs you can run the following query against cattrack database

      SELECT
      hosts.name as host_name,
      build_configurations.name AS build_configuration_name,
      test_configurations.name AS test_configurations_name,
      test_runs.name AS test_run_name,
      test_cases.name as test_case_name,
      test_runs.revision,
      test_runs.occurred_at,
      test_runs.id
      FROM test_runs
      RIGHT JOIN hosts ON hosts.id = test_runs.host_id
      RIGHT JOIN build_configurations ON build_configurations.test_run_id = test_runs.id
      RIGHT JOIN test_configurations ON test_configurations.build_configuration_id = build_configurations.id
      RIGHT JOIN groups ON groups.test_configuration_id = test_configurations.id
      RIGHT JOIN test_cases ON test_cases.group_id = groups.id
      WHERE test_cases.id IN (SELECT test_case_id FROM test_case_outputs WHERE output LIKE '%invalid argument: NaN%') ORDER BY occurred_at DESC

        Activity

        Peter Donald made changes -
        Field Original Value New Value
        Description An intermittent failure occurs on ia32 when the bootimage is opt compiled. The last time it happened was at

        http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx64.anu.edu.au/sanity.217/FullAdaptiveMarkCompact/default/SPECjbb2005/SPECjbb2005/Output.txt

        The build configurations it occurs in include; production (x10), FullAdaptiveMarkCompact (x3), FullAdaptiveCopyMS (x7) and FullAdaptiveGenCopy (x2)

        To identify the occasions where this occurs you can run the following query against cattrack database

        SELECT hosts.name as host_name, build_configurations.name AS build_configuration_name, test_configurations.name AS test_configurations_name, test_runs.name AS test_run_name, test_cases.name as test_case_name, test_runs.revision, test_runs.occurred_at, test_runs.id FROM test_runs RIGHT JOIN hosts ON hosts.id = test_runs.host_id RIGHT JOIN build_configurations ON build_configurations.test_run_id = test_runs.id RIGHT JOIN test_configurations ON test_configurations.build_configuration_id = build_configurations.id RIGHT JOIN groups ON groups.test_configuration_id = test_configurations.id RIGHT JOIN test_cases ON test_cases.group_id = groups.id WHERE test_cases.id IN (SELECT test_case_id FROM test_case_outputs WHERE output LIKE '%invalid argument: NaN%') ORDER BY occurred_at DESC
        An intermittent failure occurs on ia32 when the bootimage is opt compiled. The last time it happened was at

        http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx64.anu.edu.au/sanity.217/FullAdaptiveMarkCompact/default/SPECjbb2005/SPECjbb2005/Output.txt

        The build configurations it occurs in include; production (x10), FullAdaptiveMarkCompact (x3), FullAdaptiveCopyMS (x7) and FullAdaptiveGenCopy (x2)

        To identify the occasions where this occurs you can run the following query against cattrack database

        SELECT
            hosts.name as host_name,
            build_configurations.name AS build_configuration_name,
            test_configurations.name AS test_configurations_name,
            test_runs.name AS test_run_name,
            test_cases.name as test_case_name,
            test_runs.revision,
            test_runs.occurred_at,
            test_runs.id
        FROM test_runs
            RIGHT JOIN hosts ON hosts.id = test_runs.host_id
            RIGHT JOIN build_configurations ON build_configurations.test_run_id = test_runs.id
            RIGHT JOIN test_configurations ON test_configurations.build_configuration_id = build_configurations.id
            RIGHT JOIN groups ON groups.test_configuration_id = test_configurations.id
            RIGHT JOIN test_cases ON test_cases.group_id = groups.id
        WHERE test_cases.id IN (SELECT test_case_id FROM test_case_outputs WHERE output LIKE '%invalid argument: NaN%') ORDER BY occurred_at DESC
        David Grove made changes -
        Fix Version/s 2.9.4 [ 14162 ]
        Ian Rogers added a comment -

        Not seen for a while and searching cattrack is an issue. Scheduling for a later release.

        Ian Rogers made changes -
        Fix Version/s 2.9.4 [ 14162 ]
        Fix Version/s 3.1 [ 14379 ]
        David Grove added a comment -

        hasn't shown up in a long time.

        David Grove made changes -
        Fix Version/s 3.2 [ 14379 ]
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Peter Donald
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: