RVM
  1. RVM
  2. RVM-589

Crash in GetStringUTFChars running xalan on ppc32-aix and ppc64-aix

    Details

    • Number of attachments :
      0

      Description

      This is the most common failure on both ppc32-aix and ppc64-aix. It seems to impact about 1 test every other run (ie, about 0.5 tests on average).

      ===== DaCapo xalan starting =====
      WARNING: attempt to get compiled method #0
      JikesRVM: internal error: recursive use of hardware exception registers (exiting)

      – Stack –
      at [0x4169dba4] Lorg/jikesrvm/runtime/RuntimeEntrypoints; deliverHardwareException(II)V at line 718
      at [0x4169dc04] <hardware trap>
      at [0x4169dc10] Lorg/jikesrvm/jni/JNIFunctions; GetStringUTFChars(Lorg/jikesrvm/jni/JNIEnvironment;ILorg/vmmagic/unboxed/Address;)Lorg/vmmagic/unboxed/Address; at line 3981
      at [0x4169dc60] <invisible method>
      at [0x4169dcc8] <native frame>
      at [0x4169dd08] <native frame>
      at [0x4169dd90] Lgnu/java/nio/VMChannel; open(Ljava/lang/String;I)I
      at [0x4169de38] Lgnu/java/nio/VMChannel; openFile(Ljava/lang/String;I)V at line 732
      at [0x4169de70] Lgnu/java/nio/FileChannelImpl; <init>(Ljava/io/File;I)V at line 151
      at [0x4169deb0] Lgnu/java/nio/FileChannelImpl; create(Ljava/io/File;I)Lgnu/java/nio/FileChannelImpl; at line 141
      at [0x4169dee0] Ljava/io/FileOutputStream; <init>(Ljava/io/File;Z)V at line 164
      at [0x4169df28] Ljava/io/FileOutputStream; <init>(Ljava/io/File;)V at line 129
      at [0x4169df50] Ldacapo/xalan/XalanHarness$XalanWorker; run()V at line 80
      at [0x4169dfb0] Lorg/jikesrvm/scheduler/RVMThread; run()V at line 595
      at [0x4169dfe8] Lorg/jikesrvm/scheduler/RVMThread; startoff()V at line 620

      One instance is: http://jikesrvm.anu.edu.au/cattrack/results/piccolo.watson.ibm.com/core-ppc32/4370/prototype/default/dacapo/xalan

      I suspect a problem is that if a GC happens at this program point we're making a mistake when interpreting the stackframes, but it's possible that there is some other problem (or that this is an indirect crash caused by the current known problems of Identity HashMaps in the bootimage).

        Activity

        David Grove made changes -
        Field Original Value New Value
        Assignee David Grove [ dgrove ]
        David Grove made changes -
        Fix Version/s 3.0 [ 13530 ]
        Fix Version/s 3.0.1 [ 14378 ]
        David Grove made changes -
        Affects Version/s 3.0 [ 13530 ]
        Fix Version/s 3.0.2 [ 14620 ]
        Fix Version/s 3.0.1 [ 14378 ]
        Affects Version/s 3.0.1 [ 14378 ]
        David Grove added a comment -

        Defer to 3.1.1

        David Grove made changes -
        Fix Version/s 3.1.1 [ 14900 ]
        Fix Version/s 3.1.0 [ 14620 ]
        David Grove added a comment -

        It appears this was yet another symptom of the problems in the reflection code that Daniel fixed a while back.

        David Grove made changes -
        Assignee David Grove [ dgrove ] Daniel Frampton [ zyridium ]
        David Grove added a comment -

        Actually was fixed a while ago and fix is in 3.1.0.

        David Grove made changes -
        Fix Version/s 3.1.1 [ 14900 ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 3.1.0 [ 14620 ]

          People

          • Assignee:
            Daniel Frampton
            Reporter:
            David Grove
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: