RVM
  1. RVM
  2. RVM-514

Pure on mathMagic breaks dacapo sunflow

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Component/s: Compiler: Optimizing
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The change in commit 14036 (specifically to the single parameter version of mathMagic) causes dacapo sunflow (from the dacapo head) to reliably fail with an image validation check (I assume some floating point error has crept in).

      This may be related to the intermittent lusearch problem.

        Activity

        Steve Blackburn added a comment -

        Further info:

        Sunflow worked on March 13 [1], r14029 [2] but has been broken since March 14 [3] , r14037 [4]. The stack trace is here [5].

        I understand that Sunflow works in our current head if you simply disable the pure annotation (Daniel?).

        [1] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080313/
        [2] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080313/jikesrvm.build.log
        [3] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080314/
        [4] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080314/jikesrvm.build.log
        [5] http://jikesrvm.anu.edu.au/~dacapo/regression/results-20080314/JIKESRVM/sunflow.default.tmp.log

        Steve Blackburn added a comment -

        The meta point here is that I am trying to move forward with the next DaCapo release, and as a background task, trying to see if we can fix Jikes RVM bugs exposed by the dacapo head.

        Daniel Frampton added a comment -

        As Steve mentioned I investigated the change in more detail and narrowed it down to just un-@Pure-ing that mathMagic method.

        Ian Rogers added a comment -

        With Daniel's help I've confirmed there's a bug in LocalCSE, we transform:

        y = tan x
        z = sin x

        into

        y = tan x
        z = y

        this is because the local CSE is only comparing arguments and not the method or address parameters.

        Ian Rogers added a comment -

        Patch committed in r14323.

        David Grove added a comment -

        reopening so I can modify fix target to 3.0


          People

          • Assignee:
            Ian Rogers
            Reporter:
            Daniel Frampton
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: