RVM
  1. RVM
  2. RVM-354

major breakage in ppc32 lnx (r13896-r13900 are suspects)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Looks like something in the commit range 13896-13900 badly broke ppc32.

      http://jikesrvm.anu.edu.au/cattrack/results/rvmppclnx64.anu.edu.au/commit/1975/regression_report

        Activity

        Ian Rogers added a comment -

        My suspicion is about the expression folding change in r13900. Expression folding will be some what different on PPC than Intel as we don't generate conditional moves for PPC. This means we can be stressing the folding of operators and ifcmps together more. PPC should show greater benefit than Intel from expression folding as a number of the expression folding rules are similar to what we do on Intel in BURS. Anyway, I need time and a PPC to narrow down what the bug is. For now we could try disabling some of the expression folding rules using the boolean at the top of the file. I have disabled folding over uninterruptible regions in r13906. Folding references and ifcmps could also be the source of the problem.

        David Grove added a comment -
        Ian Rogers added a comment -

        From:

        http://jikesrvm.anu.edu.au/cattrack/results/excalibur.watson.ibm.com/core-ppc64/2020/regression_report

        it looks like 13907 will have cleared it up (13906 seemed to expose problems on Intel, which is odd as we do less expression folding with 13906). This means the problem is with expression folding (or latent bug exposed from) and not with the change to scalar replacement of aggregates.

        When I get chance I'd like to look into the ppc failures, but for now its more important that the trunk is stable.

        David Grove made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            David Grove
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: