Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.9.0.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      rvmx86lnx32.anu.edu.au
    • Number of attachments :
      0

      Description

      This error started appearing in dacapo after the change to new thread model. See below for examples. It appeared intermittently prior to that.

      To find the other tests where this also happened you can execute the following SQL on the cattrack database.
      SELECT
      ('http://jikesrvm.anu.edu.au/cattrack/results/' || hosts.name || '/' || test_runs.variant || '.' || test_runs.id || '/' || build_configurations.name || '/' || test_configurations.name || '/' || groups.name || '/' || test_cases.name || '/' || test_case_executions.name ||'/Output.txt') AS uri,
      test_runs.start_time
      FROM test_runs
      RIGHT JOIN hosts ON hosts.id = test_runs.host_id
      RIGHT JOIN build_configurations ON build_configurations.test_run_id = test_runs.id
      RIGHT JOIN test_configurations ON test_configurations.build_configuration_id = build_configurations.id
      RIGHT JOIN groups ON groups.test_configuration_id = test_configurations.id
      RIGHT JOIN test_cases ON test_cases.group_id = groups.id
      RIGHT JOIN test_case_executions ON test_case_executions.test_case_id = test_cases.id
      WHERE
      test_case_executions.id IN (SELECT owner_id FROM test_case_execution_outputs WHERE output LIKE '%invalid frame address%')
      ORDER BY test_runs.start_time DESC

      Sample output of running SQL

      uri start_time
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32b.anu.edu.au/sanity.992/BaseBaseMarkCompact/default/dacapo/fop/default/Output.txt 2007-09-10 03:41:14.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32b.anu.edu.au/sanity.992/BaseBaseMarkCompact/default/jni/TestGC/default/Output.txt 2007-09-10 03:41:14.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32b.anu.edu.au/sanity.978/BaseBaseMarkCompact/default/dacapo/pmd/default/Output.txt 2007-09-09 03:40:53.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.977/BaseBaseMarkCompact/default/ipsixql/Ipsixql/default/Output.txt 2007-09-09 03:40:34.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.977/FullAdaptiveMarkCompact/default/SPECjvm98/_201_compress/default/Output.txt 2007-09-09 03:40:34.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.977/FullAdaptiveMarkCompact/default/jni/t3GT3/default/Output.txt 2007-09-09 03:40:34.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.916/production/default/SPECjbb2005/SPECjbb2005/default/Output.txt 2007-09-03 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.902/FullAdaptiveMarkSweep/default/SPECjbb2000/SPECjbb2000/default/Output.txt 2007-09-02 03:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.862/production/default/jsr166-tck/AtomicLongArrayTest/default/Output.txt 2007-08-26 03:01:15.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.838/FullAdaptiveMarkCompact/default/dacapo/eclipse/default/Output.txt 2007-08-22 03:01:23.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.832/FullAdaptiveGenRC/default/jBYTEmark/jBYTEmark/default/Output.txt 2007-08-21 03:01:14.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.828/development/default/SPECjbb2000/SPECjbb2000/default/Output.txt 2007-08-20 19:00:57.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.828/development/default/dacapo/xalan/default/Output.txt 2007-08-20 19:00:57.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.800/development/default/SPECjbb2005/SPECjbb2005/default/Output.txt 2007-08-17 03:01:16.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.792/FullAdaptiveGenRC/default/jBYTEmark/jBYTEmark/default/Output.txt 2007-08-16 03:01:18.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.784/production/default/SPECjbb2005/SPECjbb2005/default/Output.txt 2007-08-15 03:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.762/production/default/dacapo/jython/default/Output.txt 2007-08-12 19:01:06.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.762/production/default/dacapo/chart/default/Output.txt 2007-08-12 19:01:06.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.762/development/default/dacapo/bloat/default/Output.txt 2007-08-12 19:01:06.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.762/production/default/dacapo/bloat/default/Output.txt 2007-08-12 19:01:06.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.762/production/default/dacapo/hsqldb/default/Output.txt 2007-08-12 19:01:06.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit.756/development/default/SPECjbb2000/SPECjbb2000/default/Output.txt 2007-08-11 23:01:02.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/production/default/dacapo/jython/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/production/default/dacapo/hsqldb/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/production/default/dacapo/chart/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/production/default/dacapo/bloat/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/development/default/dacapo/jython/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/development/default/dacapo/hsqldb/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.754/development/default/dacapo/bloat/default/Output.txt 2007-08-11 19:00:58.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/production/default/dacapo/hsqldb/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/development/default/dacapo/hsqldb/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/production/default/dacapo/bloat/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/development/default/dacapo/jython/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/production/default/dacapo/jython/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/production/default/dacapo/chart/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.746/development/default/dacapo/bloat/default/Output.txt 2007-08-10 19:00:59.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/development/default/dacapo/bloat/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/production/default/dacapo/bloat/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/production/default/dacapo/chart/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/development/default/dacapo/jython/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/development/default/dacapo/hsqldb/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/production/default/dacapo/hsqldb/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.738/production/default/dacapo/jython/default/Output.txt 2007-08-09 19:00:55.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.730/production/default/dacapo/jython/default/Output.txt 2007-08-08 19:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.730/development/default/dacapo/bloat/default/Output.txt 2007-08-08 19:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.730/production/default/dacapo/bloat/default/Output.txt 2007-08-08 19:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.730/production/default/dacapo/hsqldb/default/Output.txt 2007-08-08 19:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.730/production/default/dacapo/chart/default/Output.txt 2007-08-08 19:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit-x87.730/development/default/dacapo/jython/default/Output.txt 2007-08-08 19:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/commit.665/production/default/SPECjbb2005/SPECjbb2005/default/Output.txt 2007-07-26 23:00:56.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.646/FullAdaptiveMarkSweep/default/dacapo/antlr/default/Output.txt 2007-07-23 03:00:50.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.639/FullAdaptiveRefCount/default/jBYTEmark/jBYTEmark/default/Output.txt 2007-07-22 03:00:45.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.602/FullAdaptiveRefCount/default/gctest/FixedLive/default/Output.txt 2007-07-17 03:00:47.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.594/FullAdaptiveRefCount/default/jBYTEmark/jBYTEmark/default/Output.txt 2007-07-16 03:00:52.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.586/FullAdaptiveRefCount/default/gctest/FixedLive/default/Output.txt 2007-07-15 03:00:52.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.577/FullAdaptiveRefCount/default/gctest/FixedLive/default/Output.txt 2007-07-14 03:00:46.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx32.anu.edu.au/sanity.569/FullAdaptiveRefCount/default/jBYTEmark/jBYTEmark/default/Output.txt 2007-07-13 03:00:52.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx64.anu.edu.au/sanity.266/BaseBaseGenCopy/default/dacapo/lusearch/default/Output.txt 2007-05-31 15:01:11.0
      http://jikesrvm.anu.edu.au/cattrack/results/rvmx86lnx64.anu.edu.au/sanity.209/BaseBaseSemiSpace/default/dacapo/lusearch/default/Output.txt 2007-05-23 15:01:09.0

        Activity

        Ian Rogers added a comment -

        Is this still an issue?

        Peter Donald added a comment -

        It still occurred as of two days ago so it looks like it is still an issue

        Ian Rogers added a comment -

        We seem to have had a run of bad MarkCompact regression tests, and RC is known to have problems. Of the other regressions we seem to get the bad frame address after some other catastrophe has occurred. Hopefully this will work itself out. I'm not sure if we can do a particular item to get it fixed for the 2.9.2 release.

        Ian Rogers added a comment -

        Without cattrack searches I can't see if this is still an issue. Moving to 2.9.4 to not impede the 2.9.3 release.

        Ian Rogers added a comment -

        I suspect this issue is dead but still cannot search cattrack.

        David Grove added a comment -

        I believe this is obsolete.


          People

          • Assignee:
            Unassigned
            Reporter:
            Peter Donald
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: