Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      NMaven should support classifiers to allow: 1) multiple builds (depending on framework) of the NMaven .NET assembly plugins; 2) the use of 3rd party assemblies that target a specific framework version. Support may require a change with Maven core. One possible approach would be that whatever methods (within Maven core) that are invoking ArtifactRepositoryLayout.pathOf(pomArtifact) should set the classifier information within the pomArtifact.

      To provide context of this issue, I prototyped a version of NMaven that supported classifiers but ran into an issue with Maven. NMaven does not put meta-data - like the version or classifier - in the file name but rather within the artifact directory structure. In the case of version, this is fairly easy to handle because both the pomArtifact and the binaryArtifact contain the version information: the ArtifactRepositoryLayout.pathOf method can append the version to the artifact path. In the case of classifier, the pomArtifact does not contain the classifier information ( artifact.getClassifier() returns null): the ArtifactRepositoryLayout.pathOf method has no way to append the classifier to the artifact path for the pom. Thus under the current Maven version, we are unable to handle transitive dependencies for artifacts with classifiers (due to not finding the pom artifact).

        Activity

        Shane Isbell added a comment -

        Some discussions occurred on the nmaven-dev list on this issue. According to Brett, the intended behavior of maven is to have one pom for multiple classifiers. Defaulting to this behavior may solve the issue, but still need to investigate the implications since NMaven is centered about the nmaven-settings file, not the profiles within the pom.xml file.


          People

          • Assignee:
            Unassigned
            Reporter:
            Shane Isbell
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: