Maven WAR Plugin
  1. Maven WAR Plugin
  2. MWAR-239

web.xml is copied into the war twice

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      1

      Description

      When using the 2.1 version of the WAR-plugin, the web.xml file is copied into the WAR-file twice.
      In both 2.1-alpha-2 and 2.1-beta-1 my project worked like it was supposed to.
      Previous version weren't tested because the filtering of deployment-descriptors wasn't available yet.

      Included a small project that can reproduce the error.

        Issue Links

          Activity

          Roland Asmann added a comment -

          Test-project is configured for 2.1-beta-1, so the current version creates correct WAR-files! Change to 2.1 to reproduce incorrect WAR.


            People

            • Assignee:
              Unassigned
              Reporter:
              Roland Asmann
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: