Maven WAR Plugin
  1. Maven WAR Plugin
  2. MWAR-220

dependencyManagement && overlay + transitive dependency = multiple versions of same dependency in WEB-INF/lib

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: overlay
    • Labels:
      None
    • Environment:
      Reproduced this on: 2.0.11, 2.1.0, 2.2.1, 3.0-alpha-7
    • Testcase included:
      yes
    • Number of attachments :
      1

      Description

      With dependencyManagement section defined I get multiple versions of spring libraries in target/cas-*/WEB-INF/lib after mvn package. If I remove the dependencyManagement section then only one version of the spring libraries are found.

      There seems to be a problem with m-war-p and overlays and dependencyManagement not using the maven GAV resolver in a proper way.. I attached a simple pom which exhibits the problem, just run mvn package to verify.

        Activity

        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


          People

          • Assignee:
            Unassigned
            Reporter:
            jieryn
          • Votes:
            4 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: