Maven Stage Plugin
  1. Maven Stage Plugin
  2. MSTAGE-7

Unable to use archiva as http source with maven-stage-plugin

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-alpha-1
    • Fix Version/s: 1.0
    • Labels:
      None
    • Number of attachments :
      1

      Description

      http-wagon-beta-2 currently not able to parse the archiva page ( http://jira.codehaus.org/browse/MRM-891 ).

      however with the fix from http://jira.codehaus.org/browse/MRM-893 and upgrade to wagon-beta-3 will solve the problem
      without change in stage plugin source code.

        Activity

        Hide
        Dan Tran added a comment -

        attached is the patch which will work without changes in archiva

        Show
        Dan Tran added a comment - attached is the patch which will work without changes in archiva
        Hide
        Jacob Robertson added a comment -

        I'm pretty sure this issue applies to the latest version of Nexus as well. We upgraded our version of nexus, and the stage plugin stopped working. The behavior was a never ending console logging of "../ found". I applied this patch locally to the stage plugin, and the problem went away.

        Show
        Jacob Robertson added a comment - I'm pretty sure this issue applies to the latest version of Nexus as well. We upgraded our version of nexus, and the stage plugin stopped working. The behavior was a never ending console logging of "../ found". I applied this patch locally to the stage plugin, and the problem went away.
        Hide
        Dennis Lundberg added a comment -

        Dan, I've read the comments in your patch. If I understand them correctly, now that the bugs in Archiva have been solved, we only need to update the Wagon dependencies in the Stage Plugin to version 1.0-beta-3 to solve this issue.

        Show
        Dennis Lundberg added a comment - Dan, I've read the comments in your patch. If I understand them correctly, now that the bugs in Archiva have been solved, we only need to update the Wagon dependencies in the Stage Plugin to version 1.0-beta-3 to solve this issue.
        Hide
        Dan Tran added a comment -

        Yes.

        Show
        Dan Tran added a comment - Yes.
        Hide
        Dennis Lundberg added a comment -

        Fixed in r1029504.

        Show
        Dennis Lundberg added a comment - Fixed in r1029504 .

          People

          • Assignee:
            Dennis Lundberg
            Reporter:
            Dan Tran
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: