Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The version 1.0-beta-1 only supports Maven 2.x.
      The branch sonar-maven-plugin-mvn-3.x adds the support of Maven 3.

        Issue Links

          Activity

          Anders Hammar added a comment -

          As there is no fix version assigned, I'm wondering what version of the mojo this is targetting? On the the Sonar users mailing list, Evgeny Mandrikov answered "next version of the mojo". Would that be v2.0?
          As Maven 3 is quite stable (and better than any of the version of Maven 2 IMO), it would be great to have the mojo support Maven 3 soon.

          Simon Brandhof added a comment -

          FYI the committed code supports maven 3.0-beta-2 but not 3.0-beta-3. It's preferable to wait for the final maven release in order to fix this issue.

          Olivier Lamy added a comment -

          IMHO this won't change .
          I have done similar changes for maven site plugin. Do you want I apply same here ?

          Simon Brandhof added a comment -

          Personally I stop working on this issue until the first RC, but of course your changes are welcome.
          Thank you very much.

          Anders Hammar added a comment -

          Simon,
          I understand your position, but I kindly ask you to please keep up with the betas. The core API should be very stable, but there is a difference between beta-2 and beta-3 as you've spotted. However, the Maven team is very responsive so you should not have any problems getting help (as you've noticed by Olivier's comment).
          Also, keeping up with the betas makes it possible to spot issues that can be fixed to ensure that Maven 3 will be the best version ever. Not doing this until a RC would delay the release of 3.0-final should you encounter a bug (or a 3.0-final version that doesn't work with the sonar plugin).

          Evgeny Mandrikov added a comment -

          Just my 2 cents: I'd like to have support for 3.0-beta-3 and drop support of 3.0-beta-2.

          Olivier Lamy added a comment -

          So I have made changes locally.
          I have the issue :

          Caused by: org.sonatype.aether.transfer.ArtifactNotFoundException: 
          Could not find artifact org.codehaus.sonar.runtime:sonar-core-maven3-plugin:jar:20100720181619
          

          And I don't know where to find this plugin ? Any Ideas ?

          Simon Brandhof added a comment -

          Strange. Are you sure that your branch is up-to-date ?

          Olivier Lamy added a comment -

          oups

          Olivier Lamy added a comment -

          rev 12463
          SNAPSHOT deployed.

          Anders Hammar added a comment -

          When the voting for Maven 3.0-beta-3 passes, would it be possible to get a release of this plugin (with support for 3.0-beta-3)?

          Olivier Lamy added a comment -

          currently call to findbugs failed

          [ERROR] Failed to execute goal org.codehaus.mojo:findbugs-maven-plugin:2.3.1:findbugs (default-cli) on project commontrunk-api: An error has occurred in FindBugs Report report generation. Could not find matching constructor for: org.codehaus.mojo.findbugs.FindbugsReportGenerator(org.codehaus.doxia.module.xhtml.XhtmlSink, java.util.PropertyResourceBundle, java.io.File, org.apache.maven.doxia.tools.DefaultSiteTool) -> [Help 1]
          org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.codehaus.mojo:findbugs-maven-plugin:2.3.1:findbugs (default-cli) on project commontrunk-api: An error has occurred in FindBugs Report report generation.
          
          Simon Brandhof added a comment -

          Indeed the code to execute maven3 plugins must also be replicated in sonar core. It's used by plugins like Findbugs. Anders, for the same reason, releasing the mojo is not enough. It will require a new release of sonar too.

          Olivier Lamy added a comment -

          uhm in fact I'm not sure findbug plugin works with maven 3.

          Evgeny Mandrikov added a comment -

          I confirm that sonar-mojo works fine with 3.0-beta-3, when findbugs-maven-plugin not used.

          Olivier Lamy added a comment -

          I have started a branch http://svn.codehaus.org/mojo/branches/findbugs-maven-plugin-MFINDBUGS-119/
          so you can try with this (btw some it failed so skip tests for installation )

          Evgeny Mandrikov added a comment -

          Cool! Thank you - I'll try it asap.

          benjamin salles added a comment -

          I succesfull test it with maven 2.2.1 and sonar 2.2

          Evgeny Mandrikov added a comment -

          Hi guys,

          This branch doesn't work for me :

           
          [INFO] --- findbugs-maven-plugin:2.3.2-SNAPSHOT:findbugs (default-cli) @ sonar-ldap-plugin ---
          [INFO] Temp File is /home/godin/projects/sonar-plugins/ldap/target/findbugsTemp.xml
          [INFO] Fork Value is true
               [java] Couldn't open /home/godin/projects/sonar-plugins/ldap/target/findbugsTemp.xml for output: java.io.FileNotFoundException: /home/godin/projects/sonar-plugins/ldap/target/findbugsTemp.xml (Is a directory)
               [java] Java Result: 1
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 13.341s
          [INFO] Finished at: Thu Sep 09 15:52:16 MSD 2010
          [INFO] Final Memory: 18M/108M
          

          And also FYI : we are going to remove usage of findbugs-maven-plugin in Sonar (SONAR-1772).

          Evgeny Mandrikov added a comment -

          So I've made fix for branch of findbugs-maven-plugin and now Sonar Mojo works fine with Maven 3.0-beta-3 and Sonar 2.3-SNAPSHOT.

          Simon Brandhof added a comment -

          Fixed in sonar-maven-plugin 2.0-beta-1.


            People

            • Assignee:
              Simon Brandhof
              Reporter:
              Simon Brandhof
            • Votes:
              11 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: