Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-683

reporting fails with Maven 3.1-A1/Eclipse Aether 0.9-M2

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0, 3.1, 3.2
    • Fix Version/s: 3.3
    • Component/s: Maven 3
    • Labels:
      None
    • Number of attachments :
      0

      Description

      since Maven core migrated to Eclipse Aether (see MNG-5354), some core ITs are failing during site plugin execution du to following execution error

      [INFO] --- maven-site-plugin:3.2:site (default-site) @ mng-3743-forkWithPluginManagement ---
      [WARNING] Error injecting: org.apache.maven.reporting.exec.DefaultMavenReportExecutor
      java.lang.NoClassDefFoundError: org/sonatype/aether/graph/DependencyFilter
      	at java.lang.Class.getDeclaredConstructors0(Native Method)
      	at java.lang.Class.privateGetDeclaredConstructors(Class.java:2416)
      	at java.lang.Class.getDeclaredConstructors(Class.java:1855)
      	at com.google.inject.spi.InjectionPoint.forConstructorOf(InjectionPoint.java:245)
      [...]
      	at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1047)
      	at com.google.inject.internal.InjectorImpl$2.get(InjectorImpl.java:993)
      	at org.eclipse.sisu.locators.LazyBeanEntry.getValue(LazyBeanEntry.java:82)
      	at org.eclipse.sisu.plexus.locators.LazyPlexusBean.getValue(LazyPlexusBean.java:52)
      	at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:259)
      	at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:239)
      	at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:233)
      	at org.apache.maven.plugins.site.AbstractSiteRenderingMojo.getReports(AbstractSiteRenderingMojo.java:229)
      	at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:121)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:105)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:170)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:555)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:158)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:616)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
      Caused by: java.lang.ClassNotFoundException: org.sonatype.aether.graph.DependencyFilter
      	at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
      	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
      	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)
      	... 60 more
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 3.979s
      [INFO] Finished at: Tue Mar 19 01:30:47 CET 2013
      [INFO] Final Memory: 10M/120M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.2:site (default-site) on project mng-3743-forkWithPluginManagement: Execution default-site of goal org.apache.maven.plugins:maven-site-plugin:3.2:site failed: A required class was missing while executing org.apache.maven.plugins:maven-site-plugin:3.2:site: org/sonatype/aether/graph/DependencyFilter
      [ERROR] -----------------------------------------------------
      

        Issue Links

          Activity

          Herve Boutemy added a comment -

          fixed in r1461431

          Max Schaefer added a comment -

          I think the problem is not fixed with 3.3. I still get this error:

          [INFO] — maven-site-plugin:3.3:site (default-site) @ thirdparty-common-dml —
          [WARNING] Error injecting: org.apache.maven.reporting.exec.DefaultMavenReportExecutor
          java.lang.NoClassDefFoundError: org/sonatype/aether/graph/DependencyFilter
          at java.lang.Class.getDeclaredConstructors0(Native Method)
          at java.lang.Class.privateGetDeclaredConstructors(Class.java:2413)
          at java.lang.Class.getDeclaredConstructors(Class.java:1855)
          at com.google.inject.spi.InjectionPoint.forConstructorOf(InjectionPoint.java:245)
          at com.google.inject.internal.ConstructorBindingImpl.create(ConstructorBindingImpl.java:99)
          at com.google.inject.internal.InjectorImpl.createUninitializedBinding(InjectorImpl.java:653)
          at com.google.inject.internal.InjectorImpl.createJustInTimeBinding(InjectorImpl.java:863)
          at com.google.inject.internal.InjectorImpl.createJustInTimeBindingRecursive(InjectorImpl.java:790)
          at com.google.inject.internal.InjectorImpl.getJustInTimeBinding(InjectorImpl.java:278)
          at com.google.inject.internal.InjectorImpl.getBindingOrThrow(InjectorImpl.java:210)
          at com.google.inject.internal.InjectorImpl.getProviderOrThrow(InjectorImpl.java:986)
          at com.google.inject.internal.InjectorImpl.getProvider(InjectorImpl.java:1019)
          at com.google.inject.internal.InjectorImpl.getProvider(InjectorImpl.java:982)
          at com.google.inject.internal.InjectorImpl.getInstance(InjectorImpl.java:1032)
          at org.eclipse.sisu.reflect.AbstractDeferredClass.get(AbstractDeferredClass.java:44)
          at com.google.inject.internal.ProviderInternalFactory.provision(ProviderInternalFactory.java:86)
          at com.google.inject.internal.InternalFactoryToInitializableAdapter.provision(InternalFactoryToInitializableAdapter.java:55)
          at com.google.inject.internal.ProviderInternalFactory$1.call(ProviderInternalFactory.java:70)
          at com.google.inject.internal.ProvisionListenerStackCallback$Provision.provision(ProvisionListenerStackCallback.java:100)
          at org.eclipse.sisu.plexus.lifecycles.PlexusLifecycleManager.onProvision(PlexusLifecycleManager.java:134)
          at com.google.inject.internal.ProvisionListenerStackCallback$Provision.provision(ProvisionListenerStackCallback.java:109)
          at com.google.inject.internal.ProvisionListenerStackCallback.provision(ProvisionListenerStackCallback.java:55)
          at com.google.inject.internal.ProviderInternalFactory.circularGet(ProviderInternalFactory.java:68)
          at com.google.inject.internal.InternalFactoryToInitializableAdapter.get(InternalFactoryToInitializableAdapter.java:47)
          at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
          at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1054)
          at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
          at com.google.inject.Scopes$1$1.get(Scopes.java:59)
          at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:41)
          at com.google.inject.internal.InjectorImpl$2$1.call(InjectorImpl.java:997)
          at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1047)
          at com.google.inject.internal.InjectorImpl$2.get(InjectorImpl.java:993)
          at org.eclipse.sisu.locators.LazyBeanEntry.getValue(LazyBeanEntry.java:82)
          at org.eclipse.sisu.plexus.locators.LazyPlexusBean.getValue(LazyPlexusBean.java:52)
          at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:259)
          at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:239)
          at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:233)
          at org.apache.maven.plugins.site.AbstractSiteRenderingMojo.getReports(AbstractSiteRenderingMojo.java:229)
          at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:121)
          at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:106)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
          at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
          at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
          at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:318)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:153)
          at org.apache.maven.cli.MavenCli.execute(MavenCli.java:555)
          at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:158)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:601)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
          Caused by: java.lang.ClassNotFoundException: org.sonatype.aether.graph.DependencyFilter
          at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
          at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
          at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)
          ... 60 more

          Robert Scholte added a comment -

          Max Schaefer, it is probably one of the reports which is failing.
          Have a look at https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound for plugins which are known to have this issue and their fixed version.

          Max Schaefer added a comment -

          Indeed. Thanks for the hint.


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Herve Boutemy
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: