Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0-beta-3
    • Fix Version/s: None
    • Component/s: inheritance, Maven 3
    • Labels:
      None
    • Testcase included:
      yes
    • Number of attachments :
      0

      Description

      as discovered in MSITE-595:

      • with M2, each report is added: child has 2 reports generated = index+summary
      • with M3, each report replaces previous one: child has 1 report = summary

      What is the expected behaviour? I'd say M2 is buggy, since POM inheritance logic usually replaces instead adding
      Should we try to stick with M2 behaviour? (if feasible, I still didn't check)

        Issue Links

          Activity

          Herve Boutemy added a comment -

          to have the same behaviour in M3 than in M2, we need a new Maven version: see ModelMerger#mergeReporting_Plugins() which is not overrided in MavenModelMerger

          and of course, this can't be done in the new format, since inheritance is not supported at all

          Lukas Theussl added a comment -

          If this cannot get fixed for 3.1, we need to document the different behaviour.

          Karl M. Davis added a comment -

          Please note that some folks (me, for example) are now relying on the Maven 3 behavior to exclude reports in child projects. If you change this behavior, a number of my projects would break as I need a way to exclude reports occasionally.

          Herve Boutemy added a comment -

          fixed as a side effect of MNG-5155: Maven 3.0.4 and later have the same behaviour than Maven 2

          IT modified in consequence in r1480782


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Herve Boutemy
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: