Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-594

release:stage does not properly compute new distroManagement.site.URL or project.URLs for projects

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: site:stage(-deploy)
    • Labels:
      None
    • Number of attachments :
      0

      Description

      In the case where you have a multi-module project and each module has its own distributionManagement.site.url which is common with projects that like their sites to be version numbered (see example beolw) the release:stage plugin fails to get the project's site properly deployed. From a brief look it seems release:sxtage is only computing a new URL for the owning project and not all the child projects. What's more it looks like its changing the site deployment URL and not the project's corresponding project URL. This results in the site deployment for children going to their original pom.xml specific locations regardless of them being 'staged' (i.e. they're not staged, they've just gone live!). Nearly as bad is that all the relative links for connecting modules and parents and banners together are broken too, as they are based upoin the project.URL which hasnt been touched by the release:stage mojo. site:stage makes a better fist of this, basically you need to remap the entire URL domain (site distro and project url) to be under some other parent space for you to successfully stage sites (see site:stage)

      This kind of mistake has come up in the past, simply put a project can define all its own settings for everything so anything that makes assumptions based on inheritence or 'defaults' is just gonna break the system.

      Example of how sub-project's defining their own site deployemtn and project URL information:

      <site>
      	<url>dav:https://example.com/maven/sites/${mvn.repoName}/${project.groupId}/${project.artifactId}/${project.version}</url>
      </site>
      <url>http://example.com/maven/sites/${mvn.repoName}/${project.groupId}/${project.artifactId}/${project.version}/</url>
      

        Activity

        Stephen Connolly added a comment -

        Not an issue with release plugin as release plugin just plain delegates to site:stage-deploy

        John Allen added a comment -

        Although it has been a while a quick re-reading of my original description would indicate that the issue does lie with the release:deploy mojo as it is directly manipulating the various URLS of the project it is trying to deploy before calling upon another plugins to carry out their function. It is thus the responsibility of the deploy mojo to do this properly for all required fields for the delegated plugins to work properly

        I.e. when considering if this is or isnt in the realm of the deploy plugin to address, consider:

        It works fine and as designed when not being called by release:deploy

        It doesnt work when being called by release:deploy

        Lukas Theussl added a comment -

        John: I'm closing this as incomplete as I am unable to reproduce without detailed version information of the plugins involved. Note that current site-plugin-2.3 has seen several fixes wrt stage(-deploy), see in particular MSITE-534, MSITE-535, MSITE-537 and related tickets. Please test with latest plugins and open another jira with a reproducible test case if the issue persists.


          People

          • Assignee:
            Lukas Theussl
            Reporter:
            John Allen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: