Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-30

site:deploy incompatibilities with m1.02

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: site:deploy
    • Labels:
      None
    • Environment:
      All
    • Number of attachments :
      0

      Description

      Deploying a site in m2 has changed since m1.
      1) m1 used the "tar" and "gunzip" command on the remote site, where m2 uses the "unzip" command. This poses a problem for be since my remote site does not support the "unzip" command, thus making the "priority" of this issue major

      1.1) Their may be desire to deploy without the use of tools like tar and zip on some site. The deploy would esentailly be a recersive copy

      2) No equivelent to m1 property maven.site.chmod.mode. I use this to allow other member is the group update and delete permission

      3) No equivelent to m1 property maven.site.publish.clean

      Their are other properties for the m1.02 not mentioned above, but I suspect the they can be calculated from m2 files, i.e. pom.xml and settings.xml.

      Paul Spencer

        Issue Links

          Activity

          Paul Spencer added a comment -

          Is this in part a WAGGON issue since it is in AbstractWaggon.createZip where the type compression, either ZIP or GZIP, is set?

          A suggestion:
          Allow the plugin/Waggon to determine what is supported on the remote side, (zip, gzip, tar,...) and then use what is available.

          Paul Spencer

          Maik Ebert added a comment -

          Is there any update about the missing property "maven.site.publish.clean"?

          Paul Spencer added a comment -

          Dennis,
          I object to this issue be downgraded from a BUG since the desired behavior worked in a prior version of the plugin.

          Although have installed unzip on my HP-UX box to get around the problem #1 of the issue, I continue to have an issues with the chmod command.

          Paul Spencer

          Dennis Lundberg added a comment -

          Paul,
          When you say "a prior version", do you mean it used to work in M1?

          Paul Spencer added a comment -

          Yes.

          Paul Spencer

          Dennis Lundberg added a comment -

          We are talking about a major version upgrade here and all features from a previous version may not there in the new version, especially if it is a major rewrite as it is in this case.

          In my book the definition of a bug is:

          "A feature that is designed to be in the software. When that feature does not work as designed it's a bug."

          That's the reason for me to change the type for this issue.

          Lukas Theussl added a comment -

          1) is tracked by MSITE-213
          2) is fixed with MSITE-141
          3) is tracked in MSITE-250

          Please open new tickets for any specific requests.


            People

            • Assignee:
              Lukas Theussl
              Reporter:
              Paul Spencer
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: