Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-286

[ERROR] ResourceManager : unable to find resource 'VM_global_library.vm' in any resource loader.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.0-beta-5
    • Fix Version/s: 2.0-beta-6
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I always get the error below:

      [INFO] Velocimacro : initialization starting.
      [INFO] Velocimacro : adding VMs from VM library template : VM_global_library.vm
      [ERROR] ResourceManager : unable to find resource 'VM_global_library.vm' in any resource loader.
      [INFO] Velocimacro : error using VM library template VM_global_library.vm : org.apache.velocity.exception.ResourceNotFoundException: Unable to find resource 'VM_global_library.vm'
      [INFO] Velocimacro : VM library template macro registration complete.

      this does not seem to affectr my builds or sites generation
      is this normal/abnormal.
      what should i do so that i get rid of this, and that my manager does not feel bad about a product that throws errors even if final result seems ok

      thanks,

      Christian-Luc

        Issue Links

          Activity

          Hide
          Marat Radchenko added a comment -

          Well, as far as I see, this is actually not a error. However looks ugly

          Related links:
          http://osdir.com/ml/jakarta.velocity.user/2004-01/msg00208.html
          http://jira.atlassian.com/browse/JRA-2123

          Show
          Marat Radchenko added a comment - Well, as far as I see, this is actually not a error. However looks ugly Related links: http://osdir.com/ml/jakarta.velocity.user/2004-01/msg00208.html http://jira.atlassian.com/browse/JRA-2123
          Hide
          Vincent Siveton added a comment -

          Duplicate MSITE-170
          Fixed in maven-site-plugin:2.0-beta-6

          Show
          Vincent Siveton added a comment - Duplicate MSITE-170 Fixed in maven-site-plugin:2.0-beta-6

            People

            • Assignee:
              Vincent Siveton
              Reporter:
              christian-Luc Houze
            • Votes:
              14 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: