Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-242

remove copy of plexus-utils sources from site plugin sources since it is a dependency

    Details

    • Type: Task Task
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta-6
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      the dependency has been uncommented, but the source code copy hasn't been removed

      classes copied are:

      • o.c.p.u.cli
      • o.c.p.u.interpolation
      • o.c.p.u.introspection
      • o.c.p.u.xml (partial: XML encoding support)

        Issue Links

          Activity

          Hide
          Dennis Lundberg added a comment -

          Removing these files would mean that we have to bump the prerequisites to maven 2.0.6. Previous version of maven always use plexus-utils-1.1, even though we declare a dependency on plexus-utils-1.4.5.

          I don't think we can set such a high prerequisite at this time, so I'd like to move this issue to a later release of the site-plugin.

          Show
          Dennis Lundberg added a comment - Removing these files would mean that we have to bump the prerequisites to maven 2.0.6. Previous version of maven always use plexus-utils-1.1, even though we declare a dependency on plexus-utils-1.4.5. I don't think we can set such a high prerequisite at this time, so I'd like to move this issue to a later release of the site-plugin.
          Hide
          Herve Boutemy added a comment -

          you're right, I didn't understand this consequence
          no problem to let this issue open and wait for a later release

          Show
          Herve Boutemy added a comment - you're right, I didn't understand this consequence no problem to let this issue open and wait for a later release
          Hide
          Dennis Lundberg added a comment -

          Beacuse of MSITE-332, and the fix for PLXUTILS-60 in r662007, we need to depend on plexus-utils-1.5 or newer.

          Show
          Dennis Lundberg added a comment - Beacuse of MSITE-332 , and the fix for PLXUTILS-60 in r662007, we need to depend on plexus-utils-1.5 or newer.
          Hide
          Dennis Lundberg added a comment -

          Fixed in r692655.

          Show
          Dennis Lundberg added a comment - Fixed in r692655 .

            People

            • Assignee:
              Dennis Lundberg
              Reporter:
              Herve Boutemy
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: